Connect to Assistant deployed on GKE via REST

Hello Forum!

I come here seeking your assistance. So the story goes as follows.

I deployed rasa-x on a Kubernetes cluster on GKE, connected to Github, Custom Action Server and everything seems fine. Yet when I try to interact with my assistant via rest on:

<IP>:<PORT>/webhooks/rasa/webhook my request times out.

I have added the rest channel to my values.yml file as seen bellow

    rasa:
        # token Rasa accepts as authentication token from...
        token: "<TOKEN>"
        tag: "1.10.14-full"
        additionalChannelCredentials:
            rest: 
                # you don't need to provide anything here

and even tried adding port 5005 to rasa as shown in the template values.yml on rasa Github.

Until now, the only way I managed to connect was by authenticating at <IP>:8000/api/auth/jwt and accessing the chat at <IP>:8000/api/chat with the bearer token provided from the first. As it is obvious this connects to the “Test your Assistant” conversation since all messages appear as Tester on Rasa-X UI and to my understanding this is the wrong way to talk to my assistant.

I think I’m missing something, and would really value any input.

1 Like

I assume you are trying to connect from outside the cluster and you’ve confirmed the ip and port exposed by the service.

The /api endpoint is being directed to Rasa X. You should be able to connect to the rasa-production pod at /core/webhooks/rasa/webhook or /webhooks/rasa/webhook (which it sounds like you’ve tried already). Give the /core... endpoint a try.

You’ll find his configuration in the nginx pod under /opt/bitnami and the file is called rasax.nginx.

Greg