Can't run rasa shell

Hello when I run rasa shell it prints “NLU model loaded. Type a message and press enter to parse it. Next message:” I don’t need NLU model I want to test my assistant in simple shell.How to solve it? How to change NLU model mode to rasa shell?

Hi, just to be sure, you’re starting RASA via

rasa shell

right? And only the NLU model is loaded. The reason for this is probably that you have only trained a NLU model. But you hit

rasa train

right? Unfortunately, this is what happens, when you have an invalid core model. There might be an error in your domain.yml or even in your stories (not sure about the last), which leads to an error in the training process. But instead of throwing a big error and doing nothing, RASA’s uses it’s fallback and just saves NLU model alone. Now that you hit

rasa shell

it only finds an NLU model and automatically loads the NLU only mode.

So, what can you do?

Easiest way to confirm is, is to look into your models folder. The name of your model should be something like ‘20200326-134135.tar.gz’ if it worked right. In your case I expect something like ‘nlu-20200327-071340.tar.gz’ starting with ‘nlu’.

So if that’s the case just go check the training log and try to find the error, if not come here again and give some more context.

Yes my models start with nlu as in example. It shows me next : Core training was skipped because no valid domain file was found. Only an nlu-model was created.Please specify a valid domain using ‘–domain’ argument or check if the provided domain file exists. What should I do?

Do you have a domain-file?

If yes, it is invalid. The format is pretty prone to (hard-to-find-)errors. Enter the content here

http://www.yamllint.com/

to check for any formal errors.

If it still doesnt work after, you might paste it here (use code formatting!) and me or someone else might have a look.

2 Likes

Thank you so much!