Cannot Install Rasa on Windows 10

I am working on Windows 10, Python 3.7.5, Anaconda installation. Tried installing within a Conda virtual environment unsuccessfully. Then moved to installing directly using clone of git repository for rasa. The same sequence of things happens, as shown in the following error log:

(rasa) PS C:\Users\witho\Desktop\rasa-work-v1> cd rasa (rasa) PS C:\Users\witho\Desktop\rasa-work-v1\rasa> pip install -r requirements.txt Collecting requests==2.22.0 Using cached Collecting boto3==1.9.146 Downloading (128kB) |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 133kB 504kB/s Collecting matplotlib==3.0.3 Downloading (9.1MB) |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 9.1MB 1.1MB/s Collecting simplejson==3.16.0 Downloading (81kB) |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 81kB 1.1MB/s Collecting attrs==19.1.0 Downloading Collecting jsonpickle==1.1 Downloading Collecting redis==3.3.5 Downloading (65kB) |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 71kB 918kB/s Collecting fakeredis==1.0.3 Downloading Collecting pymongo==3.8.0 Downloading (317kB) |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 327kB 939kB/s Collecting numpy==1.16.3 Downloading (11.9MB) |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 11.9MB 656kB/s Collecting scipy==1.2.1 Downloading (30.0MB) |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ | 17.5MB 939kB/s eta 0:00:14ERROR: Exception: Traceback (most recent call last): File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_vendor\urllib3\”, line 425, in _error_catcher yield File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_vendor\urllib3\”, line 507, in read data = if not fp_closed else b"" File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_vendor\cachecontrol\”, line 62, in read data = File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\http\”, line 457, in read n = self.readinto(b) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\http\”, line 501, in readinto n = self.fp.readinto(b) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\”, line 589, in readinto return self._sock.recv_into(b) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\”, line 1071, in recv_into return, buffer) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\”, line 929, in read return, buffer) socket.timeout: The read operation timed out

During handling of the above exception, another exception occurred:

Traceback (most recent call last): File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\cli\”, line 153, in _main status =, args) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\commands\”, line 382, in run resolver.resolve(requirement_set) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\”, line 201, in resolve self._resolve_one(requirement_set, req) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\”, line 365, in _resolve_one abstract_dist = self._get_abstract_dist_for(req_to_install) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\”, line 313, in _get_abstract_dist_for req, self.session, self.finder, self.require_hashes File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\operations\”, line 194, in prepare_linked_requirement progress_bar=self.progress_bar File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\”, line 465, in unpack_url progress_bar=progress_bar File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\”, line 316, in unpack_http_url progress_bar) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\”, line 551, in _download_http_url _download_url(resp, link, content_file, hashes, progress_bar) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\”, line 253, in _download_url hashes.check_against_chunks(downloaded_chunks) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\utils\”, line 80, in check_against_chunks for chunk in chunks: File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\”, line 223, in written_chunks for chunk in chunks: File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\utils\”, line 160, in iter for x in it: File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_internal\”, line 212, in resp_read decode_content=False): File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_vendor\urllib3\”, line 564, in stream data =, decode_content=decode_content) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_vendor\urllib3\”, line 529, in read raise IncompleteRead(self._fp_bytes_read, self.length_remaining) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\”, line 130, in exit self.gen.throw(type, value, traceback) File β€œC:\Users\witho\Anaconda3\envs\rasa\lib\site-packages\pip_vendor\urllib3\”, line 430, in _error_catcher raise ReadTimeoutError(self._pool, None, β€œRead timed out.”) pip._vendor.urllib3.exceptions.ReadTimeoutError: HTTPSConnectionPool(host=β€˜’, port=443): Read timed out.

It seems your network is not stable

create a virtual env and try

I had originally tried to install rasa-x in a Conda-created virtual environment, receiving the same error log.

I removed all Conda virtual environments, updated Anaconda packages via Conda, created a new virtual environment for rasa-x, and proceeded with the command for installing rasa-x. I get errors on installation. It appears that there are incompatible package versions. Welcome any ideas you might have as I need rasa in my work. See attached listing with error log.rasa-x-install-error-log.txt (38.7 KB)

Hi @twmiller,

Something is going wrong with the compilation of C routines that come with the httptools package. I would like to figure out why that is, and am trying to reproduce it on my system, but was not yet able too. All works OK for me. It is probably something with the compiler on your computer.

To get you going without having to figure out compiler issues, a work-around is to first install the httptools package from the conda packages, and then use pip to install rasa-x. You can do it by using this sequence of commands:

(base) $ conda create --name rasa-x python=3.7
(base) $ conda activate rasa-x
(rasa-x) $ conda install -c conda-forge httptools
(rasa-x) $ pip install rasa-x --extra-index-url

If something similar happens with another python package that has C or C++ extensions, you can just repeat it, and first install the conda package.

To find the proper conda install command, google something like this conda install httptools, which brings you to a page with the correct conda installation command:

The nice thing about conda packages is that they are already compiled for your system and you do not need to have a compiler on your system. You can read more about it here:


I hope the above proposal to use conda packages is working, but I also had a closer look at the error message in your log.

The compiler complains that it cannot find the header file io.h .

That particular include file comes with the Windows 10 SDK.

I suspect that you either:

  • do not have the Windows 10 SDK installed
  • or Visual Studio is not properly configured to include the ucrt header folder in which the io.h file resides

You can find the Windows 10 SDK here:

Arjaan, Thank you so much for this additional information. I installed the Windows 10 developer SDK and followed your updated instructions from the previous note. I did have to add a timeout argument in pip to get it to run: --timeout 1000 I received one non-fatal error: ERROR: botocore 1.13.28 has requirement python-dateutil<2.8.1,>=2.1; python_version >= β€œ2.7”, but you’ll have python-dateutil 2.8.1 which is incompatible. Attempts to update python-dateutil were unsuccessful, as it appears that 2.8.1 is the most recent version: (rasa-x) PS C:\Users\witho\Desktop\rasa-work-v1> pip install python-dateutil Requirement already satisfied: python-dateutil in c:\users\witho\anaconda3\envs\rasa-x\lib\site-packages (2.8.1)

Regardless, rasa executed successfully.

As I am teaching a course with Rasa winter term, I created instructions for students. (See attached file.) Welcome any ideas from others who are trying to help students get started with Rasa.rasa-getting-started-instructions.txt (1.6 KB)

1 Like

I am getting below error, can you please help to resolve that error.

Hi @sravan2366,

Can you describe in what order did you do the installation steps? Please list every command in the order you issued them.

It would also be useful if you can copy/paste the whole terminal output you get from those commands into a log.txt file, and attach it to your post.

Tom (@twmiller), thanks for the confirmation that it worked after you added the Windows 10 developer SKD, and for posting the getting started instructions !

I received similar errors when trying to install under Python 3.8.0. I resolved the issues by installing a virtual environment under Python 3.7.5. I also encountered difficulties associated with Conda support of Powershell and a missing CUDA dll to support my GPU-enabled system. I updated instructions to my students as shown in the attached file.rasa-installation-getting-started-v002.txt (2.9 KB)

log.txt (38.1 KB) Attached log error file…

Hi @sravan2366, thanks for providing the full log.txt.

There seems to be something wrong with the tensorflow package that is stored in your cache, where already downloaded packages are stored. I found the possible solution on StackOverflow:

A possible solution is to use the --no-cache-dir option on the pip install command, which will result in pip downloading fresh copies of every package.

Can you try this command, and see if that fixes the issue?

$ pip install --no-cache-dir rasa-x --extra-index-url 

Thanks @Arjaan for your help, it’s working now…

Good to see additional pip options to ensure that the installation process is a success. I have updated instructions for students accordingly. Note that there are issues with regard to Windows 10 GPU systems and TensorFlow 2.0 requirements for CUDA 10.0, which are discussed under the Troubleshooting entries at the end of the file. Now on the fourth version of these instructions. rasa-installation-getting-started-v004.txt (4.9 KB)