Trying to install Rasa and Rasa X on Win10, June 2021

Guys, i’ve got all sorts of errors trying to follow the instructions. Unfortunately, I’m having to follow different instructors without a single continuous set of instructions, and piece together bits and pieces from across the internet.

Is there at all, one training video/instruction that shows from start to finish, how to install Rasa and Rasa X, in complete order on Windows 10?

Something that includes the VS Code installation (plus any additional packages to install) and Anaconda etc would be great. It seems the current Rasa tutorials are already out of date, and disjointed.

@hgoona Hi. You need to create the fresh conda environment with python 3.6 or 3.7 or 3.8

Downgrade the pip version to 20.2

Then install

pip3 install rasa==2.6.2
pip3 install rasa-sdk==2.6.0
pip install rasa-x==0.40.0 --extra-index-url https://pypi.rasa.com/simple

If you have trained the model with the last version, do train the model again as per new version if you are copying the old project.

The current version of RASA 41.X having some kind of issue, majorly pip3 issue and resolver.

Try for this process, if you have any issue we are here to help you!

I guess you will still see some Warning messages. Do share that with us. Good Luck!

thanks @nik202 – do i need to uninstal my Anaconda and VS Code installations and start again?

And how do i create a fresh install of Rasa? Do i need to delete some folders or Add/Remove and programs ??

@hgoona No, Just create the new condo environment for rasa 3.8 and follow the above steps.

Follow this https://youtu.be/GlR60CvTh8A time:2:12 how she creating the condo enviornment.

whihc python should i use in the code ? (specify python==3.8.10 or ==3.8 ) ?

@hgoona 3.8 will be fine.

1 Like

@nik202 thanks… okay… so i’ve finished installing Rasa 2.7.1, fresh, using Python 3.8.

How do i downgrade Rasa and Pip before the Rasa X commands?

@hgoona pip version to pip install pip==20.2 --user

pip install rasa-x==0.40.0 --extra-index-url https://pypi.rasa.com/simple

1 Like

@nik202 awesome! … do i skip the pip3 install rasa-sdk==2.6.0 ?

go straight to the rasa x install command?

@hgoona no follow as mention rasa==2.6.2 and so on.

oh damn… okay … so i need to downgrade everything else then!? (sorry if my questions are basic - i’m super new to this! )

Currently: (rasa) C:\Rasa>rasa --version Rasa Version : 2.7.1 Minimum Compatible Version: 2.6.0 Rasa SDK Version : 2.7.0 Rasa X Version : None Python Version : 3.8.0 Operating System : Windows-10-10.0.19041-SP0 Python Path : c:\users\hiranga\anaconda3\envs\rasa\python.exe

@hgoona after conda environment just follow above please.

it came to this error on the SDK install line:

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

rasa 2.6.2 requires multidict<5.0,>=4.6, but you’ll have multidict 5.1.0 which is incompatible.

pip3 install rasa-sdk==2.6.0 --use-feature=2020-resolver

1 Like

Okay- that one worked! Great. So. Rasa 2.6.2 installed. Rasa SDK 2.6.0 installed. But then Rasa X failed ( command: pip3 install rasa-x==0.40.0 --extra-index-url https://pypi.rasa.com/simple )

Error is: ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

sanic-jwt 1.6.0 requires pyjwt==2.0.0, but you'll have pyjwt 2.1.0 which is incompatible.
rasa 2.6.2 requires multidict<5.0,>=4.6, but you'll have multidict 5.1.0 which is incompatible.
Successfully installed GitPython-3.1.18 Mako-1.1.4 MarkupSafe-2.0.1 alembic-1.4.3 gitdb-4.0.7 pika-1.2.0 python-editor-1.0.4 rasa-x-0.40.0 ruamel.yaml-0.16.13 ruamel.yaml.clib-0.2.4 sanic-jwt-1.6.0 smmap-4.0.0 ujson-1.35
WARNING: You are using pip version 20.2; however, version 21.1.3 is available.
You should consider upgrading via the 'C:\Users\Hiranga\anaconda3\envs\rasa\python.exe -m pip install --upgrade pip' command.

@hgoona pip install rasa-x==0.40.0 --extra-index-url https://pypi.rasa.com/simple

same error :frowning:

> ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

sanic 20.12.3 requires multidict<6.0,>=5.0, but you’ll have multidict 4.7.6 which is incompatible. Successfully installed multidict-4.7.6 ruamel.yaml-0.16.13 ruamel.yaml.clib-0.2.4 WARNING: You are using pip version 20.2; however, version 21.1.3 is available. You should consider upgrading via the ‘C:\Users\Hiranga\anaconda3\envs\rasa\python.exe -m pip install --upgrade pip’ command.

(rasa) C:\Rasa>

@hgoona buddy you messed up :slight_smile: follow again but step by step please.

oh man… do you know where i messed it up??!

@hgoona I can’t tell you on this.