0.39.0 - server quick install, rasa-x pod pending due to missing pv

I’m having trouble doing a reinstall on a new server with the server quick install script.

(this is a pretty vanilla installation - the only exception being I’m setting an environment variable to enable the rest channel & using the -E flag in my quick install command)

# -E flag applies environment variables from the current user for `sudo`

curl -s get-rasa-x.rasa.com | sudo -E bash

All of the pods get created except for the rasa-x pod which sits at “pending” and never initializes.

I used kubectl describe pod and saw it appears to be an issue with persistent volume:

Events:
  Type     Reason            Age    From               Message
  ----     ------            ----   ----               -------
  Warning  FailedScheduling  3h43m  default-scheduler  0/1 nodes are available: 1 pod has unbound immediate PersistentVolumeClaims.

The persistent volume claim for rasa-rasa-x-claim has a status of “Pending” - I think used a describe command and see this:

root@server6:~# kubectl describe pvc rasa-rasa-x-claim
Name:          rasa-rasa-x-claim
Namespace:     rasa
StorageClass:  
Status:        Pending
Volume:        
Labels:        app.kubernetes.io/instance=rasa
               app.kubernetes.io/managed-by=Helm
               app.kubernetes.io/name=rasa-x
               app.kubernetes.io/version=0.38.1
               helm.sh/chart=rasa-x-1.8.8
Annotations:   meta.helm.sh/release-name: rasa
               meta.helm.sh/release-namespace: rasa
Finalizers:    [kubernetes.io/pvc-protection]
Capacity:      
Access Modes:  
VolumeMode:    Filesystem
Used By:       rasa-rasa-x-5857cf77b7-xdxp9
Events:
  Type    Reason         Age                    From                         Message
  ----    ------         ----                   ----                         -------
  Normal  FailedBinding  34s (x901 over 3h45m)  persistentvolume-controller  no persistent volumes available for this claim and no storage class is set

Then I ran the command to display all of my persistent volumes. And the I think I’m missing one for rasa-x.

root@server6:~# kubectl get pv
NAME                                       CAPACITY   ACCESS MODES   RECLAIM POLICY   STATUS   CLAIM                                 STORAGECLASS   REASON   AGE
pvc-997768f2-d824-4a41-967a-470b36cdfc0b   8Gi        RWO            Delete           Bound    rasa/redis-data-rasa-redis-master-0   local-path              3h46m
pvc-5ff34ee0-dc6a-45b8-9fad-85a1d438a693   8Gi        RWO            Delete           Bound    rasa/data-rasa-postgresql-0           local-path              3h46m
pvc-6a67ff03-d60a-4236-b801-a735cc84f847   8Gi        RWO            Delete           Bound    rasa/data-rasa-rabbit-0               local-path              3h46m

What can I do to try to figure out why install is failing to create a persistent volume?

Sorry - also, during installation the following message is displayed and the spinner continues:

Deploying Rasa X ...
-No resources found in rasa namespace.
1 Like

In my continued troubleshooting this afternoon, I tried specifying older Rasa X & Rasa version combinations from the compatibility matrix pages.

Even when downgrading to 0.38 and 0.37 (and corresponding Rasa version) the persistent volume does not seem to be getting created.

Well this morning I did my daily uninstall-reinstall and this time the persistent volume got created. (shrug!) The rasa-x pod is now running.

This is great, I’d still love to understand if there is a workaround if we get into this state again.

Same problem. Trying to install rasa-x on an EC2 instance.

Unfortunately uninstall/install does not help. Any other ideas what the problem might be / how it could be solved?