You didn't configure an endpoint to run this custom action

Hi, i wrote a custom action and it just send a string back to the user. I added it to the actions category in domain.yml and i wrote my custom action in file.

Then i trained my bot using rasa train

and then i ran my code using rasa shell

But when the place that action is executed runs, my bot gives me this error.

The model predicted the custom action ‘my_action_name’, but you didn’t configure an endpoint to run this custom action.

FYI Every line in my endpoint is commented out.

Everything you need is here --> Actions

1 Like

I know that and i read it. i went through the doc and thats why i’m asking. Can you be more specific about the problem please. @IgNoRaNt23

Okay, i solved my problem. I haven’t run the command rasa run actions

After my server is up, i ran the bot using rasa shell and then my custom action worked. :slightly_smiling_face:

Interesting. With me it´s the other way round. Or probably if I run rasa run action after “2020-08-14 16:35:47 INFO root - Rasa server is up and running” it´s hanging up.

If I run rasa shell and type the intent for my custom action it displays the rasa.core.actions.action - The model predicted the custom action ‘action_get_db’, but you didn’t configure an endpoint to run this custom action. Please take a look at the docs and set an endpoint configuration via the --endpoints flag. Actions 2020-08-14 16:36:47 ERROR rasa.core.processor - Encountered an exception while running action ‘action_get_db’. Bot will continue, but the actions events are lost. Please check the logs of your action server for more information." error.

I am sorry to admit I do not understand how to set the endpoint configuration. To me the explanation in the rasa documentation is missing detail. i mean simply typing --endpoints flag or a command of that sort is only gonna give me an error.

You havn’t enable the webhook from endpoints.yml file uncomment the following lines in the file

 url: "http://localhost:5055/webhook"

I have below enabled in my endpoint.yml and my action server is also running. Still getting same error. I am using DB connectivity in my action_endpoint: url: “http://localhost:5055/webhook

Can you share the Github link for your Rasa project to review the code @poojadeshmukh?

domain.yml (3.4 KB) Dear Sir, Dear Sir, Yes, I’ll send you the part I’m working on and the problems I’m having! My current topic is to get the questions in an exam for the user to test. I made a bot according to the Vietnamese recognition part

  1. Part 1, the structure does:
  • config.yml, do you use default library to recognize Vietnamese, can you please take a look and help me

Pic: config.yml

Pic: nlu.yml

Pic: domain.yml

In this file domain.yml, I have created a slot set with form of status_end_exam, my wish is that when it is true, I will not render the question from the test anymore, and if it is false, I will continue to execute the question rendering loop.

Pic: stories.yml

I have bolded the part I can’t do, after each time I want to redo the question rendering until the end of the exam. In the file, I have created a global variable to increase the number of questions myself. and problem: when i say intent: start_exam, the action alway return nlu.yml (2.3 KB) rules.yml (131 Bytes) stories.yml (3.6 KB) uttter_default