The model predicted the custom action 'action_goals', but you didn't configure an endpoint to run this custom action. Please take a look at the docs and set an endpoint configuration via the --endpoints flag


I’m getting error when I do a post request to Rasa.

The error is: The model predicted the custom action ‘action_goals’, but you didn’t configure an endpoint to run this custom action. Please take a look at the docs and set an endpoint configuration via the --endpoints flag. Actions

My post request is: curl -XPOST http://localhost:5005/webhooks/rest/webhook -d ‘{“sender”:“default”,“message”:“mbps”}’

My action server is up and running: Action endpoint is up and running on http://localhost:5055

My endpoints file is: action_endpoint: url: “http://localhost:5055/webhook

To load my server: rasa run --enable-api -m policiesTranslator_julio2020/models/20200722-190540.tar.gz --debug --endpoints policiesTranslator_julio2020/endpoints.yml

I’m totally blocked with this issue, the ERROR message is asking me to configure an endpoint but I’m supposed to be done with such configuration… Any help will be much appreciated!

hey have you solved this issue . i am also getting the same error . Even after configuring the endpoints.yml file still asking me to configure … i am deploying rasa action and rasa server on heroku

Hi, could you share your actions file? Or at least, the snippet where you define the action?

This files contains your custom actions which can be used to run

custom Python code.

See this guide on how to implement these action:

Custom Actions

This is a simple example for a custom action which utters “Hello World!”

from typing import Any, Text, Dict, List from rasa_sdk import Action, Tracker from rasa_sdk.executor import CollectingDispatcher import smtplib from email.mime.multipart import MIMEMultipart from email.mime.text import MIMEText

class ActionSubmit(Action): def name(self) → Text: return “action_submit”

  def run(self, dispatcher: CollectingDispatcher,
          tracker: Tracker,
          domain: Dict[Text, Any]) -> List[Dict[Text, Any]]:

      dispatcher.utter_message(text="thanks for providing the details, We have sent you a mail at {}".format(tracker.get_slot("email")))
      return []

  def SendEmail(toaddr, subject, message):
      fromaddr = ""
      # instance of MIMEMultipart
      msg = MIMEMultipart()
      # storing the senders email address
      msg['From'] = fromaddr
      # storing the receivers email address
      msg['To'] = toaddr
      # storing the subject
      msg['Subject'] = subject
      # string to store the body of the mail
      body = message
      # attach the body with the msg instance
      msg.attach(MIMEText(body, 'plain'))
      s = smtplib.SMTP('', 587)
      # Authentication
          s.login(fromaddr, "ustad5042141ZMEE&&H&")
          # Converts the Multipart msg into a string
          text = msg.as_string()
          # sending the mail
          s.sendmail(fromaddr, toaddr, text)
          print("An Error occured while sending email.")
          # terminating the session

Are you running locally? Have you started the action server? Do you have an endpoints.yml file?