What happen with this problem

when I run “rasa shell -m models/xxx.tar.gz”,it show me follow exception:

WARNING rasa.cli.utils - ‘models/2019091211735.tar.gz’ does not exist. Using default value ‘models’ instead.

rasa.core.agent - Could not load model due to Unable to load named entity extractor from C:\Users\鄢明辉\AppData\Local\Temp\tmpjqu6dwnf\nlu\component_2_MitieEntityExtractor.dat.

in fact,when I run the same project on my other pc,it work well. so I don’t know what happen I hope somebody can tell me how to solve this problem,thanks

HI @minghuiyan, Do you have any files at all in your models directory?

I’m guessing the model you specified in your rasa shell command doesn’t exist in the models directory. You may need to run rasa train to rebuild your model.

If it doesn’t matter (meaning you don’t need to run a specific model file) - you can just try rasa shell with no parameters and it’ll pick up the latest one.

in fact,models directory do exist ,when i run rasa shell with no parameters,it take the same Error.

I train the model in my server and copy model to local pc, I don’t know if it matters,I try to reinstall the dependencies