Websocket issue: "The client is using an unsupported version of the Socket.IO or Engine.IO protocols"

I’ve got an issue struggling to get websocket working.

When I send test msg on postman, I get this response: “The client is using an unsupported version of the Socket.IO or Engine.IO protocols” image

I dont know what Im missing???

When I run rasa --version I get this read out in vscode:

C:\Python310\lib\site-packages\rasa\core\tracker_store.py:1048: MovedIn20Warning: Deprecated API features detected! These feature(s) are not compatible with SQLAlchemy 2.0. To prevent incompatible upgrades prior to updating applications, ensure requirements files are pinned to "sqlalchemy<2.0". Set environment variable SQLALCHEMY_WARN_20=1 to show all deprecation warnings. Set environment variable SQLALCHEMY_SILENCE_UBER_WARNING=1 to silence this message. (Background on SQLAlchemy 2.0 at: https://sqlalche.me/e/b8d9) Base: DeclarativeMeta = declarative_base() Rasa Version : 3.5.4 Minimum Compatible Version: 3.5.0 Rasa SDK Version : 3.5.0 Python Version : 3.10.11 Operating System : Windows-10-10.0.19045-SP0 Python Path : C:\Python310\python.exe

Do you know where I’m going wrong?

Also, I am running my rasa server, via docker. So my container setup was done like this: docker run -it -p 8080:8080 -v ${pwd}:/app rasa/rasa:latest-full run --enable-api --port 8080 --cors="*" ^Is this correct, too?

Please help!

@nik202 I think you solved this for others but i seem to still be stuck!

I checked my sanic --version: Sanic 21.12.2; Routing 0.7.2

Any ideas??

I’ve realised Postman has a new request method for Websockets, so I tried that. Still getting error:

@sonam by chance, have you got experience on this?

@hgoona check the rasa GitHub issue page as I last used version 3.0 only and it was working, In later versions, I didn’t get the time to explore.

Try to create the new env and install rasa 2.8 or 3.0 and test its working or not. You will get a better idea.

Sorry @nik202 - please refer to THIS NEW POST

Is this the correct port to send to? image

Hey, Hi I am facing the same connecting websocket. Is there any solution available for it

You can try this: