RASA 3.2.6 unsupported version of the Socket.IO

Hi All I am new to RASA and I am trying to install the last version working step by step with documentation but when I am running RASA by using
rasa run --cors “*” --debug I am getting this issue

I have Rasa Version : 3.2.6 Minimum Compatible Version: 3.0.0 Rasa SDK Version : 3.2.0 Python Version : 3.8.0 Operating System: Windows-10-10.0.19041-SP0 As I can see mostly in the same problem they advise upgrading or downgrading Sanic but when I did that I get incompatible conflicts so I am back to using 21.12.0 again to resolve all conflict

And I tried all the suggested upgrade downgrade of versions and still no result

can I have some help, please thanks

@nik202 Can i have some help please

I also has pip list

Package Version

absl-py 0.13.0 aio-pika 8.1.1 aiofiles 0.8.0 aiohttp 3.7.4 aiormq 6.4.1 APScheduler 3.7.0 astunparse 1.6.3 async-timeout 3.0.1 attrs 21.2.0 bidict 0.22.0 boto3 1.24.56 botocore 1.27.56 CacheControl 0.12.11 cachetools 4.2.4 certifi 2022.6.15 cffi 1.15.1 chardet 3.0.4 charset-normalizer 2.1.1 click 8.1.3 cloudpickle 1.6.0 colorama 0.4.5 colorclass 2.2.2 coloredlogs 15.0.1 colorhash 1.0.4 cryptography 37.0.4 cycler 0.11.0 dask 2022.2.0 dnspython 1.16.0 docopt 0.6.2 fbmessenger 6.0.0 fire 0.4.0 Flask 2.2.2 Flask-SocketIO 5.0.0 flatbuffers 2.0 fsspec 2022.7.1 future 0.18.2 gast 0.4.0 google-auth 1.35.0 google-auth-oauthlib 0.4.6 google-pasta 0.2.0 greenlet 1.1.2 grpcio 1.47.0 h11 0.9.0 h5py 3.7.0 httpcore 0.11.1 httptools 0.4.0 httpx 0.15.4 humanfriendly 10.0 idna 3.3 importlib-metadata 4.12.0 importlib-resources 5.9.0 itsdangerous 2.1.2 Jinja2 3.1.2 jmespath 1.0.1 joblib 1.0.1 jsonpickle 2.0.0 jsonschema 4.4.0 kafka-python 2.0.2 keras 2.7.0 Keras-Preprocessing 1.1.2 kiwisolver 1.4.4 libclang 14.0.6 locket 1.0.0 Markdown 3.4.1 MarkupSafe 2.1.1 matplotlib 3.3.4 mattermostwrapper 2.2 msgpack 1.0.4 multidict 5.2.0 networkx 2.6.3 numpy 1.19.5 oauthlib 3.2.0 opt-einsum 3.3.0 packaging 20.9 pamqp 3.2.0 partd 1.3.0 Pillow 9.2.0 pip 22.1.2 prompt-toolkit 3.0.28 protobuf 3.19.4 psycopg2-binary 2.9.3 pyasn1 0.4.8 pyasn1-modules 0.2.8 pycparser 2.21 pydot 1.4.2 PyJWT 2.4.0 pykwalify 1.8.0 pymongo 3.10.1 pyparsing 3.0.9 pyreadline3 3.4.1 pyrsistent 0.18.1 pyTelegramBotAPI 4.7.0 python-crfsuite 0.9.8 python-dateutil 2.8.2 python-engineio 4.3.4 python-socketio 5.7.1 pytz 2021.3 PyYAML 6.0 questionary 1.10.0 randomname 0.1.5 rasa 3.2.6 rasa-sdk 3.2.0 redis 3.5.3 regex 2022.4.24 requests 2.28.1 requests-oauthlib 1.3.1 requests-toolbelt 0.9.1 rfc3986 1.5.0 rocketchat-API 1.25.0 rsa 4.9 ruamel.yaml 0.16.13 ruamel.yaml.clib 0.2.6 s3transfer 0.6.0 sanic 21.12.0 Sanic-Cors 2.0.1 sanic-jwt 1.8.0 sanic-routing 0.7.2 scikit-learn 0.24.2 scipy 1.7.3 sentry-sdk 1.3.1 setuptools 61.2.0 six 1.16.0 sklearn-crfsuite 0.3.6 slackclient 2.9.4 sniffio 1.2.0 SQLAlchemy 1.4.40 tabulate 0.8.10 tarsafe 0.0.3 tensorboard 2.10.0 tensorboard-data-server 0.6.1 tensorboard-plugin-wit 1.8.1 tensorflow 2.7.3 tensorflow-addons 0.15.0 tensorflow-estimator 2.7.0 tensorflow-hub 0.12.0 tensorflow-io-gcs-filesystem 0.26.0 termcolor 1.1.0 terminaltables 3.1.10 threadpoolctl 3.1.0 toolz 0.12.0 tqdm 4.64.0 twilio 6.50.1 typeguard 2.13.3 typing-extensions typing-utils 0.1.0 tzlocal 2.1 ujson 5.4.0 urllib3 1.26.11 wcwidth 0.2.5 webexteamssdk 1.6.1 websockets 10.3 Werkzeug 2.2.2 wheel 0.37.1 wincertstore 0.2 wrapt 1.14.1 yarl 1.8.1 zipp 3.8.1

@Rasha_Kyl try setup the new environment for rasa with 2.11 version and check. Do check my other post, there you can find the solution relate to socket.io as I never integrated rasa webchat for 3.2.X…

I am sorry I didn’t get your point 2.11 version of what? Do you mean to recreate a new clean env and install rasa into it??? how did I specify the version last time I didn’t put any so it suppose to be the last one isn’t it?

Yes, correct creat a new conda environment and install pip install rasa=2.11and follow the other process in same ways and let me know. Else you need to try different socket and sanic version to integrate rasawebchat.

Rasa 3.x supports Socket.io 4.x. It could be that your client is using a library that supports 3.x. What client are you using?

I am sorry but I am new to Rasa I am currtnly using image

and I am trying to connect to my web page using webchat

So what Rasa Client did you mean and how can I get the version of it ??

Thank you but isn’t it too much waste to come back from the 3.2.6 version of rasa into 2.2(I feel like it is too old ) or do you mean it is the most compatible version I am new to rasa and I needed it for my graduation project and I may need to use Rasa X also isn’t that will make me use an old version of everything?

If experiment or downgrade from 3 to 2.x is a waste of time for you, it’s a matter of max 5 or 10mins , then so sorry you need to learn alot my friend. In data scientist world or Chatbot all you need is experiment and possible finding solution, will that be a waste of time in that scenario?

Good Luck for your graduation and project.

Sorry for this misunderstanding I meant a waste of the version updates coming back from 3.2.6 to 2.2 not wasting od my time for sure I have already installed more than 3 different versions trying to find the best compatible without problem but all I try was trying >3.x

There shouldn’t be a compatibility issue with the Rasa webchat widget so I’m not sure what’s going on there. You might try the Botfront widget which is open source. I have a post on it here.

It’s ok don’t be sorry, as far as I am concerned I have last time integrated botfront and rasa 3.1. You can follow their post of Stephen. If you want that I look at your code, let me know in advance. I can manage 10 mins.