V3 docker-compose install script error

Ran the v3 install script (0.42.6) but it fails here. Any idea what I should do?:

@simonm3 what method you are using to install rasa x?

The docker compose quick install script on wsl2/ubuntu

@simonm3 what is the configuration of server, I mean RAM, CPU and HD?

@simonm3 can you try this version:

curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/0.42.5/install.sh


curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/0.39.3/install.sh

With the following steps mentioned in the link, I know you must know: Docker Compose Installation

I had 42.5 installed and working but wanted to upgrade to the new rasa3. So I deleted the /etc/rasa folder and ran the 42.6 script. However now 42.5 won;t install either. So perhaps it is the lack of disk space - for some reason I have only 20GB left so not sure what is using it up. Will find out where the space has gone and free some up tomorrow.

@simonm3 no worries, take your time and do let me know. please mention @ and nik202 for help.

Thanks @nik202 I moved my wsl2 to a larger drive. still got the same error. Tried the script on a clean AWS machine and it worked. Created a new wsl2 VM and it worked. Still don’t know what the problem was but will just use that and hope it does not happen again.

@simonm3 It’s good now its working, then what’s the issue?