Utter_template not displaying text, only button since 1.0.1 migration

I’m having some weird bugs since I migrated my code to Rasa 1.0.1.

First, I have a custom action that uses utter_template to return a template with a button and some text. Only the button is displayed and the text is not. I tried adding some prints to the source code and the utter_template from rasa_sdk seems to be working fine, it’s just not showing the text in the UI, only the button (rasa X conversation history or chatroom). Utter_template is working fine when it’s only text and no button.

Secondly, when I press a button in the UI, the payload with the backslash (/blabla) is now printing instead of the message and confidence is not always = 1.0 (intent is not forced)

Format of template in my domain.file :
       - text: "random message here"
         - title: "Show me some more options"
           payload: '/show_options'

This is all really weird to me because it was working without probablem before updating to Rasa 1.0.1. Any insight is appreciated!

Edit : tried to define the button directly into the custom action with a text only template using utter_button_template and I have the same problem, text is not sent to the user, just the button.

It seems like the text not printing is a UI problem. But i’m still wondering about the payload being sent to user instead of the message, and buttons not being 1.0 confidence as this happens on different UIs

Hi @Amsterdoom,

Were you able to solve the issue? I’m facing a similar issue with buttons after migrating to RASA 1.0.1. The buttons are displayed on the UI only after the next message is sent and immediately disappeared. It was all working fine even on Slack UI before upgrading to 1.0.1. Please let me know if its a bug in RASA X or something to do with my code.


Hi @Mounika,

Apparently, this is intented behavior and was introduced in 1.0 so that people can only click buttons if they are the last message received so that the flow of the conversation is not messed up by the user pressing a button that is no longer relevant. However this means sending a transition message following the buttons is no longer possible, e.g “if your question is not in this (button) list, please reformulate”

Hi @Amsterdoom,

The buttons are not displayed when they are supposed to be. Only the text is displayed. The buttons are displayed after the next message is sent and then again they immediately disappear within a second.