Urgent USER Not authenticated error

Hi, Here is how I used to call rasa, but i’m getting a NotAuthorized error since this morning before a demo presentation.

rasa run -m models/20190902-112301. tar.gz --endpoints endpoints.yml --debug --enable-api -t ‘ODZ3MjJ23525OWQwOS00MDc0LTlmZTAtOWY3ODEwMjc3MTFm’

The error is displayed when I call to run an action on this endpoint: 'conversations/{conversation_id}/execute

Does anyone encounter this ? Thanks

Hi @Rogers_ntr, can you post the error you’re running into? Does it provide any more information?

In a stitch, you can always try not passing a -t token, then you shouldn’t need one to hit the endpoint.

@erohmensing Thanks for your reply. Here is the error from the HTTP API.

 {'version': '1.2.1', 'status': 'failure', 'message': 'User is not authenticated.', 'reason': 'NotAuthenticated', 'details': {}, 'help': 'https://rasa.com/docs/rasa/user-guide/running-the-server/#security-considerations', 'code': 401}

Are you passing the token when you try to make the request? Also have you tried it without the token?

Thanks very much @erohmensing! I try to run rasa without passing the token and it works now. It seems suprising as I used to pass the token as a command line argument. When I call the execute endpoint, I pass the token as a query parameter.