Unable to install Rasa X with Rasa open source 3.1

I am using Rasa 3.1.1 for my chatbot development. I tried installing Rasa X(1.1) but could not install it. The error I m getting is

ERROR: Failed building wheel for xmlsec Failed to build xmlsec ERROR: Could not build wheels for xmlsec, which is required to install pyproject.toml-based projects

I tried everything I could find over internet but no luck.

Ensure you have all dependencies for building xmlsec.

Can you please share list of dependencies for the same. I could not find anything extra which is not installed. If you can share that will be really helpful

  apt-get install -y --no-install-recommends \
      python3 \
      python3-venv \
      python3-pip \
      python3-dev \
      curl \
      wget \
      git-core \
      libpq-dev \
      openssh-client \
      graphviz-dev \
      openssl \
      libssl-dev \
      libffi7 \
      libffi-dev \
      libpng-dev \
      libxml2-dev \
      libxmlsec1-dev \
      libxmlsec1-openssl \
      build-essential \
      wget \