How to Install RASA X (on development environment)?

Hi, how can I Install RASA X (on development environment)? I can’t find a specific installation instructions on the user guide: Installation

Somewhere (not in the above mentioned user guide) I found the instruction:

(venv) $ pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

but I got errors:

Looking in indexes: https://pypi.org/simple, https://pypi.rasa.com/simple
Collecting rasa-x
  Downloading https://pypi.rasa.com/api/package/rasa-x/rasa_x-0.27.7-py3-none-any.whl (1.6 MB)
     |████████████████████████████████| 1.6 MB 683 kB/s
Requirement already satisfied: kafka-python<2.0,>=1.4 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.4.7)
Requirement already satisfied: aiohttp<4.0,>=3.6 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (3.6.2)
Requirement already satisfied: python-dateutil<2.9,>=2.8 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (2.8.1)
Requirement already satisfied: sanic-jwt<1.4.0,>=1.3.2 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.3.2)
Requirement already satisfied: ruamel.yaml<0.16,>=0.15 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (0.15.100)
Requirement already satisfied: sanic-cors<0.11.0,>=0.10.0.post3 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (0.10.0.post3)
Requirement already satisfied: psycopg2-binary<3.0.0,>=2.8.2 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (2.8.5)
Collecting GitPython<4.0.0,>=3.0.8
  Downloading GitPython-3.1.1-py3-none-any.whl (450 kB)
     |████████████████████████████████| 450 kB 1.0 MB/s
Requirement already satisfied: pika<2.0.0,>=1.1.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.1.0)
Collecting pyyaml<6.0.0,>=5.1.2
  Using cached PyYAML-5.3.1.tar.gz (269 kB)
Requirement already satisfied: tensorflow-estimator<2.2.0,>=2.1.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (2.1.0)
Requirement already satisfied: questionary<1.6.0,>=1.5.1 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.5.2)
Collecting alembic<2.0.0,>=1.0.10
  Using cached alembic-1.4.2.tar.gz (1.1 MB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... error
  ERROR: Command errored out with exit status 1:
   command: /home/solyaris/venv/bin/python3 /home/solyaris/venv/lib/python3.6/site-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmpw797f52r
       cwd: /tmp/pip-install-l8c54wbv/alembic
  Complete output (10 lines):
  Traceback (most recent call last):
    File "/home/solyaris/venv/lib/python3.6/site-packages/pip/_vendor/pep517/_in_process.py", line 257, in <module>
      main()
    File "/home/solyaris/venv/lib/python3.6/site-packages/pip/_vendor/pep517/_in_process.py", line 240, in main
      json_out['return_val'] = hook(**hook_input['kwargs'])
    File "/home/solyaris/venv/lib/python3.6/site-packages/pip/_vendor/pep517/_in_process.py", line 85, in get_requires_for_build_wheel
      backend = _build_backend()
    File "/home/solyaris/venv/lib/python3.6/site-packages/pip/_vendor/pep517/_in_process.py", line 76, in _build_backend
      obj = getattr(obj, path_part)
  AttributeError: module 'setuptools.build_meta' has no attribute '__legacy__'
  ----------------------------------------
ERROR: Command errored out with exit status 1: /home/solyaris/venv/bin/python3 /home/solyaris/venv/lib/python3.6/site-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmpw797f52r Check the logs for full command output.

Similar issue: Unable to run rasa x

BTW, I already installed rasa on a Ubuntu 18.04, following instructions on the mentioned user guide and rasa basics functionalities seem to run correctly:

(venv) $ python3 --version
Python 3.6.9
(venv) $ pip3 --version
pip 20.0.2 from /home/solyaris/venv/lib/python3.6/site-packages/pip (python 3.6)
(venv) $ rasa --version
Rasa 1.9.7

Thanks for your help giorgio

i think upgrading the setuptools will do the job just run :: sudo pip3 --upgrade setuptools :: then run the installation again try it tell us if it worked

Thanks Youssef for the suggestion. I successfully installed doing this:

$ sudo pip3 install setuptools -U
$ sudo pip3 install tqdm -U
(venv) $ pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

and finally …

(venv) $ rasa x
Starting Rasa X in local mode... 🚀
...

Notes:

  • As python ignorant. I do not understand why I needed the required sudo pip3, because I run under a virtual environment (as suggested in RASA installation guide).

  • I suggest RASA owners to improve the Build contextual chatbots and AI assistants with Rasa pages because the installation phase is a bit unclear. By example, the rasa x installation is not specified/detailed, and (other topic) I the connectors page is not reachable from the above mentioned user guide, and there are a lot of minor errors; I’ll maybe open an issue on github.


rasa x installation log:

(venv) $ pip install rasa-x --extra-index-url https://pypi.rasa.com/simple
Looking in indexes: https://pypi.org/simple, https://pypi.rasa.com/simple
Requirement already satisfied: rasa-x in /home/solyaris/venv/lib/python3.6/site-packages (0.27.7)
Requirement already satisfied: alembic<2.0.0,>=1.0.10 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.4.2)
Requirement already satisfied: tensorflow-estimator<2.2.0,>=2.1.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (2.1.0)
Requirement already satisfied: SQLAlchemy<2.0.0,>=1.3.3 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.3.16)
Requirement already satisfied: aiohttp<4.0,>=3.6 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (3.6.2)
Requirement already satisfied: kafka-python<2.0,>=1.4 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.4.7)
Requirement already satisfied: cryptography<3.0,>=2.7 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (2.9.2)
Requirement already satisfied: GitPython<4.0.0,>=3.0.8 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (3.1.1)
Requirement already satisfied: sanic-jwt<1.4.0,>=1.3.2 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.3.2)
Requirement already satisfied: psycopg2-binary<3.0.0,>=2.8.2 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (2.8.5)
Requirement already satisfied: sanic-cors<0.11.0,>=0.10.0.post3 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (0.10.0.post3)
Requirement already satisfied: rasa<2.0.0,>=1.9.5 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.9.7)
Requirement already satisfied: requests<3.0,>=2.23 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (2.23.0)
Requirement already satisfied: pika<2.0.0,>=1.1.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.1.0)
Requirement already satisfied: isodate<0.7,>=0.6 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (0.6.0)
Requirement already satisfied: setuptools>=41.0.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (46.1.3)
Requirement already satisfied: ujson<2.0,>=1.35 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.35)
Requirement already satisfied: python-dateutil<2.9,>=2.8 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (2.8.1)
Requirement already satisfied: pyyaml<6.0.0,>=5.1.2 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (5.3.1)
Requirement already satisfied: sanic<20.0.0,>=19.12.2 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (19.12.2)
Requirement already satisfied: apscheduler<4.0,>=3.6 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (3.6.3)
Requirement already satisfied: questionary<1.6.0,>=1.5.1 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (1.5.2)
Requirement already satisfied: ruamel.yaml<0.16,>=0.15 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (0.15.100)
Requirement already satisfied: attrs<20.0,>=19.3 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (19.3.0)
Requirement already satisfied: jsonschema<4.0,>=3.2 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa-x) (3.2.0)
Requirement already satisfied: Mako in /usr/lib/python3/dist-packages (from alembic<2.0.0,>=1.0.10->rasa-x) (1.0.7)
Requirement already satisfied: python-editor>=0.3 in /home/solyaris/venv/lib/python3.6/site-packages (from alembic<2.0.0,>=1.0.10->rasa-x) (1.0.4)
Requirement already satisfied: yarl<2.0,>=1.0 in /home/solyaris/venv/lib/python3.6/site-packages (from aiohttp<4.0,>=3.6->rasa-x) (1.4.2)
Requirement already satisfied: typing-extensions>=3.6.5; python_version < "3.7" in /home/solyaris/venv/lib/python3.6/site-packages (from aiohttp<4.0,>=3.6->rasa-x) (3.7.4.2)
Requirement already satisfied: idna-ssl>=1.0; python_version < "3.7" in /home/solyaris/venv/lib/python3.6/site-packages (from aiohttp<4.0,>=3.6->rasa-x) (1.1.0)
Requirement already satisfied: async-timeout<4.0,>=3.0 in /home/solyaris/venv/lib/python3.6/site-packages (from aiohttp<4.0,>=3.6->rasa-x) (3.0.1)
Requirement already satisfied: multidict<5.0,>=4.5 in /home/solyaris/venv/lib/python3.6/site-packages (from aiohttp<4.0,>=3.6->rasa-x) (4.7.5)
Requirement already satisfied: chardet<4.0,>=2.0 in /usr/lib/python3/dist-packages (from aiohttp<4.0,>=3.6->rasa-x) (3.0.4)
Requirement already satisfied: six>=1.4.1 in /home/solyaris/venv/lib/python3.6/site-packages (from cryptography<3.0,>=2.7->rasa-x) (1.14.0)
Requirement already satisfied: cffi!=1.11.3,>=1.8 in /home/solyaris/venv/lib/python3.6/site-packages (from cryptography<3.0,>=2.7->rasa-x) (1.14.0)
Requirement already satisfied: gitdb<5,>=4.0.1 in /home/solyaris/venv/lib/python3.6/site-packages (from GitPython<4.0.0,>=3.0.8->rasa-x) (4.0.4)
Requirement already satisfied: pyjwt in /home/solyaris/venv/lib/python3.6/site-packages (from sanic-jwt<1.4.0,>=1.3.2->rasa-x) (1.7.1)
Requirement already satisfied: sanic-plugins-framework>=0.9.0 in /home/solyaris/venv/lib/python3.6/site-packages (from sanic-cors<0.11.0,>=0.10.0.post3->rasa-x) (0.9.2)
Requirement already satisfied: colorhash<1.1.0,>=1.0.2 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.0.2)
Requirement already satisfied: pytz<2020.0,>=2019.1 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (2019.3)
Requirement already satisfied: scipy<2.0.0,>=1.4.1 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.4.1)
Requirement already satisfied: tensorflow-addons>=0.7.1 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (0.9.1)
Requirement already satisfied: packaging<19.1,>=19.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (19.0)
Requirement already satisfied: tqdm<4.32.0,>=4.31.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (4.31.1)
Requirement already satisfied: cloudpickle<1.3.0,>=1.2.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.2.2)
Requirement already satisfied: twilio<6.27,>=6.26 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (6.26.3)
Requirement already satisfied: python-telegram-bot<12.0,>=11.1 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (11.1.0)
Requirement already satisfied: gevent<1.5.0,>=1.4.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.4.0)
Requirement already satisfied: webexteamssdk<1.2.0,>=1.1.1 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.1.1)
Requirement already satisfied: tensorflow<2.2,>=2.1 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (2.1.0)
Requirement already satisfied: python-socketio<4.5,>=4.4 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (4.4.0)
Requirement already satisfied: prompt-toolkit<3.0,>=2.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (2.0.10)
Requirement already satisfied: scikit-learn<0.23,>=0.22 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (0.22.2.post1)
Requirement already satisfied: absl-py<0.10,>=0.9 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (0.9.0)
Requirement already satisfied: fbmessenger<6.1.0,>=6.0.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (6.0.0)
Requirement already satisfied: boto3<2.0,>=1.12 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.12.45)
Requirement already satisfied: terminaltables<3.2.0,>=3.1.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (3.1.0)
Requirement already satisfied: numpy<2.0,>=1.16 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.18.3)
Requirement already satisfied: colorclass<2.3,>=2.2 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (2.2.0)
Requirement already satisfied: rocketchat_API<0.7.0,>=0.6.31 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (0.6.36)
Requirement already satisfied: async_generator<1.11,>=1.10 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.10)
Requirement already satisfied: python-engineio<3.12,>=3.11 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (3.11.2)
Requirement already satisfied: rasa-sdk<2.0.0,>=1.9.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.9.0)
Requirement already satisfied: redis<4.0,>=3.4 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (3.4.1)
Requirement already satisfied: oauth2client==4.1.3 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (4.1.3)
Requirement already satisfied: tensorflow-probability<0.8,>=0.7 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (0.7.0)
Requirement already satisfied: pykwalify<1.8.0,>=1.7.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.7.0)
Requirement already satisfied: mattermostwrapper<2.3,>=2.2 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (2.2)
Requirement already satisfied: coloredlogs<11.0,>=10.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (10.0)
Requirement already satisfied: matplotlib<3.2,>=3.1 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (3.1.3)
Requirement already satisfied: networkx<2.5.0,>=2.4.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (2.4)
Requirement already satisfied: pydot<1.5,>=1.4 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.4.1)
Requirement already satisfied: pymongo[srv,tls]<3.9.0,>=3.8.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (3.8.0)
Requirement already satisfied: tensorflow_hub<0.8,>=0.7 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (0.7.0)
Requirement already satisfied: slackclient<3.0.0,>=2.0.0 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (2.5.0)
Requirement already satisfied: sklearn-crfsuite<0.4,>=0.3 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (0.3.6)
Requirement already satisfied: jsonpickle<1.4,>=1.3 in /home/solyaris/venv/lib/python3.6/site-packages (from rasa<2.0.0,>=1.9.5->rasa-x) (1.3)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/lib/python3/dist-packages (from requests<3.0,>=2.23->rasa-x) (1.22)
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python3/dist-packages (from requests<3.0,>=2.23->rasa-x) (2018.1.18)
Requirement already satisfied: idna<3,>=2.5 in /usr/lib/python3/dist-packages (from requests<3.0,>=2.23->rasa-x) (2.6)
Requirement already satisfied: httptools>=0.0.10 in /home/solyaris/venv/lib/python3.6/site-packages (from sanic<20.0.0,>=19.12.2->rasa-x) (0.1.1)
Requirement already satisfied: httpx==0.9.3 in /home/solyaris/venv/lib/python3.6/site-packages (from sanic<20.0.0,>=19.12.2->rasa-x) (0.9.3)
Requirement already satisfied: websockets<9.0,>=7.0 in /home/solyaris/venv/lib/python3.6/site-packages (from sanic<20.0.0,>=19.12.2->rasa-x) (8.1)
Requirement already satisfied: aiofiles>=0.3.0 in /home/solyaris/venv/lib/python3.6/site-packages (from sanic<20.0.0,>=19.12.2->rasa-x) (0.5.0)
Requirement already satisfied: uvloop>=0.5.3; sys_platform != "win32" and implementation_name == "cpython" in /home/solyaris/venv/lib/python3.6/site-packages (from sanic<20.0.0,>=19.12.2->rasa-x) (0.14.0)
Requirement already satisfied: tzlocal>=1.2 in /home/solyaris/venv/lib/python3.6/site-packages (from apscheduler<4.0,>=3.6->rasa-x) (2.0.0)
Requirement already satisfied: pyrsistent>=0.14.0 in /home/solyaris/venv/lib/python3.6/site-packages (from jsonschema<4.0,>=3.2->rasa-x) (0.16.0)
Requirement already satisfied: importlib-metadata; python_version < "3.8" in /home/solyaris/venv/lib/python3.6/site-packages (from jsonschema<4.0,>=3.2->rasa-x) (1.6.0)
Requirement already satisfied: pycparser in /home/solyaris/venv/lib/python3.6/site-packages (from cffi!=1.11.3,>=1.8->cryptography<3.0,>=2.7->rasa-x) (2.20)
Requirement already satisfied: smmap<4,>=3.0.1 in /home/solyaris/venv/lib/python3.6/site-packages (from gitdb<5,>=4.0.1->GitPython<4.0.0,>=3.0.8->rasa-x) (3.0.2)
Requirement already satisfied: typeguard>=2.7 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow-addons>=0.7.1->rasa<2.0.0,>=1.9.5->rasa-x) (2.7.1)
Requirement already satisfied: pyparsing>=2.0.2 in /home/solyaris/venv/lib/python3.6/site-packages (from packaging<19.1,>=19.0->rasa<2.0.0,>=1.9.5->rasa-x) (2.4.7)
Requirement already satisfied: pysocks; python_version >= "3.0" in /home/solyaris/venv/lib/python3.6/site-packages (from twilio<6.27,>=6.26->rasa<2.0.0,>=1.9.5->rasa-x) (1.7.1)
Requirement already satisfied: future>=0.16.0 in /home/solyaris/venv/lib/python3.6/site-packages (from python-telegram-bot<12.0,>=11.1->rasa<2.0.0,>=1.9.5->rasa-x) (0.18.2)
Requirement already satisfied: greenlet>=0.4.14; platform_python_implementation == "CPython" in /home/solyaris/venv/lib/python3.6/site-packages (from gevent<1.5.0,>=1.4.0->rasa<2.0.0,>=1.9.5->rasa-x) (0.4.15)
Requirement already satisfied: requests-toolbelt in /home/solyaris/venv/lib/python3.6/site-packages (from webexteamssdk<1.2.0,>=1.1.1->rasa<2.0.0,>=1.9.5->rasa-x) (0.9.1)
Requirement already satisfied: opt-einsum>=2.3.2 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (3.2.1)
Requirement already satisfied: keras-applications>=1.0.8 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (1.0.8)
Requirement already satisfied: tensorboard<2.2.0,>=2.1.0 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (2.1.1)
Requirement already satisfied: grpcio>=1.8.6 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (1.28.1)
Requirement already satisfied: gast==0.2.2 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (0.2.2)
Requirement already satisfied: protobuf>=3.8.0 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (3.11.3)
Requirement already satisfied: wheel>=0.26; python_version >= "3" in /usr/lib/python3/dist-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (0.30.0)
Requirement already satisfied: keras-preprocessing>=1.1.0 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (1.1.0)
Requirement already satisfied: termcolor>=1.1.0 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (1.1.0)
Requirement already satisfied: wrapt>=1.11.1 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (1.12.1)
Requirement already satisfied: astor>=0.6.0 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (0.8.1)
Requirement already satisfied: google-pasta>=0.1.6 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (0.2.0)
Requirement already satisfied: wcwidth in /home/solyaris/venv/lib/python3.6/site-packages (from prompt-toolkit<3.0,>=2.0->rasa<2.0.0,>=1.9.5->rasa-x) (0.1.9)
Requirement already satisfied: joblib>=0.11 in /home/solyaris/venv/lib/python3.6/site-packages (from scikit-learn<0.23,>=0.22->rasa<2.0.0,>=1.9.5->rasa-x) (0.14.1)
Requirement already satisfied: botocore<1.16.0,>=1.15.45 in /home/solyaris/venv/lib/python3.6/site-packages (from boto3<2.0,>=1.12->rasa<2.0.0,>=1.9.5->rasa-x) (1.15.45)
Requirement already satisfied: s3transfer<0.4.0,>=0.3.0 in /home/solyaris/venv/lib/python3.6/site-packages (from boto3<2.0,>=1.12->rasa<2.0.0,>=1.9.5->rasa-x) (0.3.3)
Requirement already satisfied: jmespath<1.0.0,>=0.7.1 in /home/solyaris/venv/lib/python3.6/site-packages (from boto3<2.0,>=1.12->rasa<2.0.0,>=1.9.5->rasa-x) (0.9.5)
Requirement already satisfied: rsa>=3.1.4 in /home/solyaris/venv/lib/python3.6/site-packages (from oauth2client==4.1.3->rasa<2.0.0,>=1.9.5->rasa-x) (4.0)
Requirement already satisfied: pyasn1-modules>=0.0.5 in /home/solyaris/venv/lib/python3.6/site-packages (from oauth2client==4.1.3->rasa<2.0.0,>=1.9.5->rasa-x) (0.2.8)
Requirement already satisfied: httplib2>=0.9.1 in /usr/lib/python3/dist-packages (from oauth2client==4.1.3->rasa<2.0.0,>=1.9.5->rasa-x) (0.9.2)
Requirement already satisfied: pyasn1>=0.1.7 in /home/solyaris/venv/lib/python3.6/site-packages (from oauth2client==4.1.3->rasa<2.0.0,>=1.9.5->rasa-x) (0.4.8)
Requirement already satisfied: decorator in /home/solyaris/venv/lib/python3.6/site-packages (from tensorflow-probability<0.8,>=0.7->rasa<2.0.0,>=1.9.5->rasa-x) (4.4.2)
Requirement already satisfied: docopt>=0.6.2 in /home/solyaris/venv/lib/python3.6/site-packages (from pykwalify<1.8.0,>=1.7.0->rasa<2.0.0,>=1.9.5->rasa-x) (0.6.2)
Requirement already satisfied: humanfriendly>=4.7 in /home/solyaris/venv/lib/python3.6/site-packages (from coloredlogs<11.0,>=10.0->rasa<2.0.0,>=1.9.5->rasa-x) (8.2)
Requirement already satisfied: cycler>=0.10 in /home/solyaris/venv/lib/python3.6/site-packages (from matplotlib<3.2,>=3.1->rasa<2.0.0,>=1.9.5->rasa-x) (0.10.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/solyaris/venv/lib/python3.6/site-packages (from matplotlib<3.2,>=3.1->rasa<2.0.0,>=1.9.5->rasa-x) (1.2.0)
Requirement already satisfied: dnspython<2.0.0,>=1.13.0; extra == "srv" in /home/solyaris/venv/lib/python3.6/site-packages (from pymongo[srv,tls]<3.9.0,>=3.8.0->rasa<2.0.0,>=1.9.5->rasa-x) (1.16.0)
Requirement already satisfied: python-crfsuite>=0.8.3 in /home/solyaris/venv/lib/python3.6/site-packages (from sklearn-crfsuite<0.4,>=0.3->rasa<2.0.0,>=1.9.5->rasa-x) (0.9.7)
Requirement already satisfied: tabulate in /home/solyaris/venv/lib/python3.6/site-packages (from sklearn-crfsuite<0.4,>=0.3->rasa<2.0.0,>=1.9.5->rasa-x) (0.8.7)
Requirement already satisfied: hstspreload in /home/solyaris/venv/lib/python3.6/site-packages (from httpx==0.9.3->sanic<20.0.0,>=19.12.2->rasa-x) (2020.4.24)
Requirement already satisfied: sniffio==1.* in /home/solyaris/venv/lib/python3.6/site-packages (from httpx==0.9.3->sanic<20.0.0,>=19.12.2->rasa-x) (1.1.0)
Requirement already satisfied: h2==3.* in /home/solyaris/venv/lib/python3.6/site-packages (from httpx==0.9.3->sanic<20.0.0,>=19.12.2->rasa-x) (3.2.0)
Requirement already satisfied: h11==0.8.* in /home/solyaris/venv/lib/python3.6/site-packages (from httpx==0.9.3->sanic<20.0.0,>=19.12.2->rasa-x) (0.8.1)
Requirement already satisfied: rfc3986<2,>=1.3 in /home/solyaris/venv/lib/python3.6/site-packages (from httpx==0.9.3->sanic<20.0.0,>=19.12.2->rasa-x) (1.4.0)
Requirement already satisfied: zipp>=0.5 in /home/solyaris/venv/lib/python3.6/site-packages (from importlib-metadata; python_version < "3.8"->jsonschema<4.0,>=3.2->rasa-x) (3.1.0)
Requirement already satisfied: h5py in /home/solyaris/venv/lib/python3.6/site-packages (from keras-applications>=1.0.8->tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (2.10.0)
Requirement already satisfied: google-auth-oauthlib<0.5,>=0.4.1 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorboard<2.2.0,>=2.1.0->tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (0.4.1)
Requirement already satisfied: google-auth<2,>=1.6.3 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorboard<2.2.0,>=2.1.0->tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (1.14.1)
Requirement already satisfied: markdown>=2.6.8 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorboard<2.2.0,>=2.1.0->tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (3.2.1)
Requirement already satisfied: werkzeug>=0.11.15 in /home/solyaris/venv/lib/python3.6/site-packages (from tensorboard<2.2.0,>=2.1.0->tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (1.0.1)
Requirement already satisfied: docutils<0.16,>=0.10 in /home/solyaris/venv/lib/python3.6/site-packages (from botocore<1.16.0,>=1.15.45->boto3<2.0,>=1.12->rasa<2.0.0,>=1.9.5->rasa-x) (0.15.2)
Requirement already satisfied: contextvars>=2.1; python_version < "3.7" in /home/solyaris/venv/lib/python3.6/site-packages (from sniffio==1.*->httpx==0.9.3->sanic<20.0.0,>=19.12.2->rasa-x) (2.4)
Requirement already satisfied: hpack<4,>=3.0 in /home/solyaris/venv/lib/python3.6/site-packages (from h2==3.*->httpx==0.9.3->sanic<20.0.0,>=19.12.2->rasa-x) (3.0.0)
Requirement already satisfied: hyperframe<6,>=5.2.0 in /home/solyaris/venv/lib/python3.6/site-packages (from h2==3.*->httpx==0.9.3->sanic<20.0.0,>=19.12.2->rasa-x) (5.2.0)
Requirement already satisfied: requests-oauthlib>=0.7.0 in /home/solyaris/venv/lib/python3.6/site-packages (from google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.2.0,>=2.1.0->tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (1.3.0)
Requirement already satisfied: cachetools<5.0,>=2.0.0 in /home/solyaris/venv/lib/python3.6/site-packages (from google-auth<2,>=1.6.3->tensorboard<2.2.0,>=2.1.0->tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (4.1.0)
Requirement already satisfied: immutables>=0.9 in /home/solyaris/venv/lib/python3.6/site-packages (from contextvars>=2.1; python_version < "3.7"->sniffio==1.*->httpx==0.9.3->sanic<20.0.0,>=19.12.2->rasa-x) (0.12)
Requirement already satisfied: oauthlib>=3.0.0 in /home/solyaris/venv/lib/python3.6/site-packages (from requests-oauthlib>=0.7.0->google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.2.0,>=2.1.0->tensorflow<2.2,>=2.1->rasa<2.0.0,>=1.9.5->rasa-x) (3.1.0)