Unable to install Rasa X locally. Tried every solution provided

Hi I recently started working with Rasa and my Rasa shell works completely fine. But I am unable to install rasa x.

These are the versions I have currently installed : image

Are you trying in windows or linux?

@hemantrattey Please update the Rasa SDK to 2.8.0 it’s mention minimum compatible version is 2.8.0. Now, I will encourage create the new fresh environment and install rasa x but downgrade pip version to 20.0.2, then show the error.

1 Like

Check this link to know the compatible version-

@SubhadipGitHub it’s good to know the compatibility matrix as you shared, but mid-release version 2.8.0 rasa, not yet updated in the matrix, please check.

Hi. I made a new environment and downgraded pip but it gave me this error while downgrading

@hemantrattey Since, how many weeks or months you are using Rasa?

These compatibility issues with Rasa are a nightmare. I have been running Rasa X from docker in order to get around them. It doesn’t solve your install issue, but if you just want to run Rasa X, this should work.

docker-compose.yml

version: "3.4"

services:
  rasa:
    image: rasa/rasa-x:latest
    ports:
      - 5002:5002
    volumes:
      - ./:/app
    command: rasa x --no-prompt -m model

Hi @nik202. I just started last week and needed a GUI interface to see how my assistant was performing. I can work with rasa shell but need to show my managers the GUI version. Finally, I have been able to resolve these error messages and was able to install Rasa X but one more error persists when I run it for which I have made a new thread.

@hemantrattey I would encourage you to use other interfaces (GUI) if you are fine with that?

@hemantrattey I will recommend in your case please see this video for rasa integration using Botfront https://youtu.be/eJMT2FovZsM

I hope it will solve your issue and you will be able to impress your manager oops managers :slight_smile: . For customization please create the new thread will update you more. Good Luck!

This looks quite promising. Will surely check it out and let you know. Thanks for all your help.

@hemantrattey Are you able to solve this issue, if yes please close this thread with the solution for others or share your own solution it will be a great help for others. Good Luck!