Unable to find dependencies Spacy

2020-05-29 15:59:14 INFO root - Starting Rasa server on http://localhost:5005 2020-05-29 15:59:15 ERROR rasa_sdk.executor - Failed to register package ‘actions’. Traceback (most recent call last): File “/home/nizar/.local/lib/python3.6/site-packages/rasa_sdk/executor.py”, line 250, in register_package self._import_submodules(package) File “/home/nizar/.local/lib/python3.6/site-packages/rasa_sdk/executor.py”, line 206, in _import_submodules package = self._import_module(package) File “/home/nizar/.local/lib/python3.6/site-packages/rasa_sdk/executor.py”, line 227, in _import_module module = importlib.import_module(name) File “/usr/lib/python3.6/importlib/init.py”, line 126, in import_module return _bootstrap._gcd_import(name[level:], package, level) File “”, line 994, in _gcd_import File “”, line 971, in _find_and_load File “”, line 955, in _find_and_load_unlocked File “”, line 665, in _load_unlocked File “”, line 678, in exec_module File “”, line 219, in _call_with_frames_removed File “/home/nizar/PycharmProjects/untitled/actions.py”, line 16, in from pyresparser import ResumeParser File “/home/nizar/.local/lib/python3.6/site-packages/pyresparser/init.py”, line 3, in from .resume_parser import ResumeParser File “/home/nizar/.local/lib/python3.6/site-packages/pyresparser/resume_parser.py”, line 6, in import spacy File “/home/nizar/.local/lib/python3.6/site-packages/spacy/init.py”, line 12, in from . import pipeline File “/home/nizar/.local/lib/python3.6/site-packages/spacy/pipeline/init.py”, line 4, in from .pipes import Tagger, DependencyParser, EntityRecognizer, EntityLinker File “pipes.pyx”, line 1, in init spacy.pipeline.pipes File “morphology.pxd”, line 13, in init spacy.syntax.nn_parser File “vocab.pxd”, line 27, in init spacy.morphology File “vocab.pyx”, line 19, in init spacy.vocab File “/home/nizar/.local/lib/python3.6/site-packages/spacy/lemmatizer.py”, line 8, in from .lookups import Lookups File “/home/nizar/.local/lib/python3.6/site-packages/spacy/lookups.py”, line 6, in from preshed.bloom import BloomFilter ModuleNotFoundError: No module named ‘preshed.bloom’

@Nizar I think your spacy seems to be broken. Try installing again

python3 -m venv .env
source .env/bin/activate
pip3 install -U spacy
pip3 install -U spacy-lookups-data
python3 -m spacy download en_core_web_sm

Also, prefer virtualenv instead of system packages. Hope it helps!