Unable to execute custom actions from rasa webchat UI


I just started working on a PoC to implement a chatbot using Rasa. I was able to build I simple chatbot which executes custom actions. The custom actions work fine when I run them from the command line. I tried implementing a UI using https://github.com/Alexmhack/Django-Rasa-Bot which uses https://github.com/mrbot-ai/rasa-webchat for the chat UI.

The issue I am facing is that when I chat with the bot via the webchat UI, none of the custom actions are being executed while they work fine via the command line.

My configuration is as below: Rasa --version = 1.1.3



socketio: user_message_evt: user_uttered bot_message_evt: bot_uttered session_persistence: false

rasa: url: “http://localhost:5002/api


action_endpoint: url: “http://localhost:5055/webhook

Command to start action endpoint server - rasa run --debug --endpoints endpoints.yml -m “rasachat/models/current” --enable-api --credentials credentials.yml actions --cors “*”

Please let me know if I have missed anything and how I can resolve this issue.

Could you post the logs from both your Rasa server and custom actions server?

@msamogh This is now resolved. I had missed a few configuration related steps. This started working after:

  1. Installing socketio on my machine.

  2. Changing the socket url port in index.html to 5005. The rasa server uses port 5005 by default and the port was set to 5500 in index.html. Point 2 in the solution here helped resolve this : chatbot - Rasa WebChat integration - Stack Overflow

In general, following everything mentioned here helped: GitHub - Alexmhack/Django-Rasa-Sockets: Rasa Chatbot using Django backend and Sockets for communication