Trouble with rasa data validate - "not a valid utterance action"


I am using Response Selector and one retrieval intent following Rasa documentation. When running rasa data validate I get the following message:

UserWarning: The action ‘utter_faq’ is used in the stories, but is not a valid utterance action. Please make sure the action is listed in your domain and there is a template defined with its name. More info at Actions

I used Response Selector in config as mentioned in documentation:

- name: ResponseSelector
    epochs: 100
    retrieval_intent: faq

I have my retrieval intents in a separate .yml file, and utterances (example: utter_faq/faq1, utter_faq/faq2) are in domain.yml. I also created a few stories and rules as advised. I have tried to put the retrieval intents in my nlu.yml file but I get the same error…

Event if I run rasa train I get this:

ActionNotFoundException: Cannot access action ‘utter_faq’, as that name is not a registered action for this domain. Available actions are:

How can I solve this?

Don’t worry about that warning, it’s because you have intents named utter_faq/x, utter_faq/y, but not just utter_faq :slight_smile:

As for this, be carefult that in your domain, you haven’t listed any regular utterances (in this case, utter_faq) under actions.

@ChrisRahme Thanks for your reply. Unfortunately this UserWarning does not allow me to train the model as it raises the ActionNotFoundException mentioned. In domain.yml I don’t list regular utterances under actions.

I also tried to move the regular utterances utter_faq to a separate responses.yml file under data>nlu>responses folder, but error is still raised. Any thoughts?

@ml2021 can you share the nlu.yml file? I hope you mention both - intent: utter_faq/faq1 and - intent: utter_faq/faq2 with some examples in nlu file?

such as just a demo example:

- intent: faq/faq1
  examples: |
    - What is your name?
    - May I know your name?
    - What do people call you?
    - Do you have a name for yourself?
- intent: faq/faq2
  examples: |
    - What's the weather like today?
    - Does it look sunny outside today?
    - Oh, do you mind checking the weather for me please?
    - I like sunny days in Berlin.


  - faq

in domain.yml

  • rule: response to faq steps:
    • intent: faq
    • action: utter_faq

@nik202 yes that is what I have described, all seem ok. Only difference from what you said is that my intents: faq/faq1intent: faq/faq2 are in a separate .yml file under data>nlu>faq.yml. But even when I cut and paste them in domain.yml, the error ir the same and I cant train the model.

Anyone facing a similar issue? Rasa version is 2.8.0

@ml2021 quite strange it should work as mention in the doc. Have you seen rasa GitHub repos and some examples there? It will help you to find the error and steps you facing and missing.

@ml2021 If you can share some code file, I can dry run the code for you and check the problem, for that I need all related files. Thanks.

@ml2021 can you share the faq1.yml and faq2.yml files

Yes unfortunately cant find a solution for this ActionNotFoundException:. @rctatman any advice you may have? thanks

What do your responses in your domain file look like? This error is usually due to a formatting problem.