Strange issue when validating

Hello! I’m new here and kind of new to Rasa as well. I had a functioning chatbot, but when I added a few more intents, and their corresponding utterances, it would give me errors when I attempted to train the model. I ran rasa data validate to see what was wrong, and it gave this error:

UserWarning: The action ‘utter_fun’ is used in the stories, but is not a valid utterance action. Please make sure the action is listed in your domain and there is a template defined with its name. More info at Actions

However it is in my domain, I checked and double-checked. It isn’t mispelled or anything. Not sure what it’s saying about a template though. Can anyone help?


Do you can post your domain.yml and stories.yml? I think more better to help you :blush:

So… the console return has a problem in yout stories.yml the function exec in ‘utter_fun’ intent

in domain.yml, confirme the utter is registered in “Intents” like:

version: '2.0'
  session_expiration_time: 60
  carry_over_slots_to_new_session: true
- greet
  - text: Hey! How are you?

in the stories.yml

- story: happy path
  - intent: greet
  - action: utter_greet

in nlu.yml

- intent: greet
  examples: |
    - hey
    - hello
    - hi
    - hello there
    - good morning
    - good evening
    - moin
    - hey there
    - let's go
    - hey dude
    - goodmorning
    - goodevening
    - good afternoon

Hello! Thanks for responding!

Here is my domain file:

version: "2.0"

  - fun

  - action_time
  - action_mood
  - action_youtube


    - text: "I like RPGs, movies, music..."

  session_expiration_time: 60
  carry_over_slots_to_new_session: true

Here is the stories file:

version: "2.0"


- story: fun path
  - intent: greet
  - action: utter_greet
  - intent: fun
  - action: utter_fun

Hope this helps

Do you have this intents too in your domain.yml?

intent: greet
action: utter_greet

What rasa version do you have? Maybe 2.2.x?

rasa --version

Do you have some responses in data/nlu.yml for this intent? Reference: Retrieval Intents throws errors in rasa data validate - #9 by santteegt

Here is the output when I ran the version command:

Rasa Version : 3.1.0 Minimum Compatible Version: 3.0.0 Rasa SDK Version : 3.1.1 Rasa X Version : None Python Version : 3.9.7

Yeah I have that in my domain, I only sent the section of the domain file with the “fun” intent and stuff. I don’t have any of the utter_ thingies under the actions section though. Should I put them there?

Thanks so much for helping!

The section location its ok Do you can make two little test?

change your domain.yml version to version: “3.1” like this example: and run rasa data validate command

If erro persisti, put utter_fun in actions too :

- utter_fun


It worked! I made the changes and ran the rasa data validate command, but it still gave the same error. I tried training the model, but this time it worked!

Thanks so much for helping, God Bless!

Thank you :smiley:

I think has some issues in stories.yml too change stories version to: version: “3.1”

probably, you will need to make this change in nlu.yml and rules.yml too

Or start new project using using this rasa version

God Bless too :smiley:

1 Like

Ok will do. Thanks again!