Training failed and Upload failed on RasaX deploy

I have faced some errors when I use RasaX for real-life conversations. Training failed on RasaX sever when I trained model and upload fail when I tried to upload model; I use server and computer as well but got the same issue both system. Docker Compose is used on

servers and computers.

  • Docker version 20.10.8, build 3967b7d
  • Rasa Version : 2.2.9
  • Rasa SDK Version : 2.2.0
  • Rasa X Version : 0.42.1
  • Python Version : 3.6.9
  • Operating System : Linux-4.15.0-153-generic-x86_64-with-Ubuntu-18.04-bionic

Please give me workable solution. i have tried since three days

1 Like

@MNR Hi,

You are using Docker compose for Rasa-X are you sure as you mentioned in the rasa version there is no Rasa X version.

I’d encourage and suggest used the rasa image 2.8.1 and rasa x 0.39.3 from the docker hub, I am not sure about the Rasa-x image as I only implemented it whilst using rasa open source.

I’d even suggest, please try the same configuration on your condo environment first, if you are able to run everything using the same, then the issue is with the docker-compose file.

Do let me know.

1 Like

Hello; Thanks for your help.

  • Rasa X Version : 0.42.1

After following your instruction I found this errors:

ERROR: manifest for rasa/rasa-x-demo:0.39.3 not found: manifest unknown: manifest unknown

{"version":"0.39.3","status":"failure","message":"See the server logs for more information.","reason":"The server encountered an internal error and cannot complete the request.","details":{},"help":null,"code":500}

@MNR check in docker hub Docker Hub the image, I guess docker pull rasa/rasa-x:0.39.5 should work for you. Try

For rasa/rasa:2.8.1

For rasa/rasa-sdk:2.8.1

Make sure, you have compatibility of version.

1 Like

Hello; Thanks for cooperating.

Now rasaX is running and upload files properly using this version

  • RASA_X_VERSION=0.39.0
  • RASA_VERSION=2.5.0

But Problem is Training failed

Your model training has failed.

Screenshot from 2021-08-13 12-09-33

What is the problem to me; I don’t understand it.

@MNR Hello, When next time you come please mention my whilst using @ nik202, and we will solve together may be online.

1 Like