Tracing action error "Couldn't create message"

I’d like to know how to trace an error related to a Rasa action. I’m just starting to build a new bot from scratch and I wanted to create an action that would tell me when the action was triggered (it would bring a message to the terminal).

In the Rasa shell, I get this message

ERROR rasa.core.actions.action - Couldn't create message for response 'utter_asana_check'.

Originally, I got the same problem when there the right intent and actions in the domain and config files, so I fixed that when I run rasa train everythig is fine, until I trigger the intent through the shell.

So, my question is two fold:

  1. Is there a general way to trace more fine-grain errors?

  2. I seem to get this error whether another terminal is running the action server or not, which I don’t understand.

Thanks and let me know if I can provide any other info

Have you tried running the CLI with --debug flag?

have you resolve this problem? I have the same problem

I had the same problem and solved it by avoiding to use the prefix “utter_” for custom actions. “utter_” seems to be reserved and mandatory for responses only: Responses

Hi@hatimk, how you resolved this problem ? Can you elaborate more ?