Telegram Exception('Bot token is not defined')

So I got a clean install of rasa running in a venv and followed the tutorial to connect telegram to add the token, verify and url to credentials.yml

I use ngrok on port 5005

I run ngrok, rasa run actions and rasa run in different terminal windows

I get this exception running rasa run:

Traceback (most recent call last):
  File "/home/erik/Sita/venv/bin/rasa", line 8, in <module>
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/rasa/", line 117, in main
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/rasa/cli/", line 126, in run**vars(args))
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/rasa/", line 57, in run
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/rasa/core/", line 175, in serve_application
    app = configure_app(
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/rasa/core/", line 116, in configure_app, app, route=route)
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/rasa/core/channels/", line 96, in register
    app.blueprint(channel.blueprint(handler), url_prefix=p)
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/rasa/core/channels/", line 194, in blueprint
    out_channel = self.get_output_channel()
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/rasa/core/channels/", line 284, in get_output_channel
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/telebot/", line 321, in set_webhook
    return apihelper.set_webhook(self.token, url, certificate, max_connections, allowed_updates, ip_address,
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/telebot/", line 267, in set_webhook
    return _make_request(token, method_url, params=payload, files=files)
  File "/home/erik/Sita/venv/lib/python3.8/site-packages/telebot/", line 73, in _make_request
    raise Exception('Bot token is not defined')
Exception: Bot token is not defined

So I also tried getting a new token, wich didn’t help

@Erike360 check the credentials.yml again and verify the tokens. @Erike360 Hope this will help you to solve your error. Good Luck!