Suggestion to rasa X

Question to developers. I’m using rasa for half a year for now, and I frequently loose some of my data because rasa X formats my domain and just deletes lines that doesn’t match pattern. Is it possible that you just move those lines to the end of the file or create additional dump file along with domain.yml? Or probably I miss something?

@gsp0din can you give an example of lines that are deleted from the domain?

I constantly have the same error: my utter template lines just disappear from domain after I run rasa x. However, they appear in rasa x gui. Therefore, after I restart rasa x, there is nothing in responses both in rasa x and domain file, because domain is still empty. domain.yml (3.6 KB)

new_domain.yml (1.2 KB)

It is constantly the same, I copy correct version of my domain and run rasa x, after that my responses just disappear.

@gsp0din which versions of rasa and rasa X are you running? Do you see any warnings about templates being renamed to responses? Perhaps this name change is messing with how the domain is dumped after it is loaded in.

I remember seeing some warnings about templates and responses, I tried to rename them, but it probably was the same, so I reverted back. I’m running 0.25.1 version. Where do you suggest me to look for warnings? Also, is there a way to install some specific version of rasa X, probably earlier version didn’t contain such bug.

They should be named responses as of 0.25.1. You can look for warnings in the rasa-x container by looking at sudo docker-compose logs rasa-x from your /etc/rasa folder.

You can install a specific version by changing the number in step 1 of the installation: Docker-Compose Quick Install

I renamed them as responses, but they just got removed, even without appearing in responses tab in rasa x.

Here what I found, I moved back to version 0.24.6, and it works fine. I also tried to move to version 0.25.0, and same error appears. Again, renaming it to responses seemingly just makes it unparsable as if rasa didn’t know that responses exists. We currently use local mode, but we are planning to move it to docker after we finish it. Is there anything else you can suggest? Probably there should be some log info when renaming to responses to see if it is actually parsed correctly.

I don’t see that in changelog. Btw I’m using local mode, might that be a problem?

Ah, yes that might be the problem indeed. We can look into that. I’d highly recommend moving to server mode, though. As of 0.26, we have a one-line deployment script that makes setting up server mode just as easy as local mode.

I would be happy to do that, but I’m totally noob in using docker etc. Regarding docker setup, after I install it to ec2, can I use it as a regular server, e.g. change files, stop/run rasa and rasa x?

It’s super simple now with the deployment script – its one command to install it. Then you can use the UI to connect it to a git repository with your assistant. That way you can change files locally and push them to git, or change them via the UI, and everything stays in sync, no starting and stopping involved