Returning empty array when running Rasa Core command line

rasa-core: 0.11.12

rara-core-sdk: 0.11.5

rasa-nlu: 0.13.7

I have successfully trained a Rasa NLU Interpreter with my training data and have confirmed that the intent and entities output are correct.

Then, I created Domain, Stories and Custom Actions in for my agent in Rasa Core. I have 2 Custom Actions where I implemented in

My story is just to execute the custom action

## story_1
* get_description("product": "a")
   - action_get_description

After training the dialogue model, I ran a Python script to try the bot on console.

interpreter = RasaNLUInterpreter("models/nlu/default/chat")

action_endpoint =EndpointConfig(url="http://localhost:5055/webhook")

agent =Agent.load("models/dialogue", interpreter=interpreter, action_endpoint=action_endpoint)

run.serve_application(agent, channel='cmdline')

But when I tried entering any sentence, it returns an empty array and it’s not uttering the lines I set in dispatcher.utter_message() in the custom actions. I’m not sure how to fix this. Thank you in advance for any suggestions.

I didn’t know that the actions server had to be run separately.

I have to run:

python -m rasa_core_sdk.endpoint --actions action

before running my script to activate the bot.

1 Like