Rasa X Unauthorized when training model

Dear community, I need your help! I install Rasa X 1.0.0 on digital ocean. Everything works fine, but I can not train a new model. When starting the training process in the UI I get the following error. Training failed Your model training has failed. When looking into the networking tab of my browser I find the following error with the request to /api/projects/default/models/jobs

{"reasons":["Authorization header not present."],"exception":"Unauthorized"}

Can anyone give a hint on what the problem is or where to find more information?

Thank you in advance, Sören

@soerenetler did you provide the proper permissions at the time of installing rasa x ? What is your method of installation can you tell?

Hi, I used the Rasa Ephemeral Installer to install Rasa X. I did log in as root.

curl -O https://rei.rasa.com/rei.sh && bash rei.sh -y
rasactl start

nothing was previously installed. So I have to restart the server after the docker installation.

I found the error in the logs.

[ERROR] Exception occurred while handling uri: ''
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/dist-packages/sanic/app.py", line 973, in handle_request
    response = await response
  File "/usr/local/lib/python3.8/dist-packages/rasax/community/api/decorators.py", line 247, in decorated_function
    return await await_and_return_response(args, kwargs, request)
  File "/usr/local/lib/python3.8/dist-packages/rasax/community/api/decorators.py", line 177, in await_and_return_response
    response = await response
  File "/usr/local/lib/python3.8/dist-packages/rasax/community/api/decorators.py", line 84, in decorated_function
    return await f(request, user=user, *args, **kwargs)
  File "/usr/local/lib/python3.8/dist-packages/rasax/community/api/blueprints/models.py", line 249, in train_model
    stack_service = stack_services[environment]
KeyError: 'worker'

I have no running worker. But I have no idea why and how to fix it.

I am facing the same issue Training and model upload failed in Rasa-X

have you found any solution?

Hi @abhishekrathi, unfortunately not. I am trying to use the Docker Compose Installation now. But there I have issues with the configuration of the admin user. Waht is your workaround?

@soerenetler please share me the issue or error in terms of docker ?

This is the error I face with docker and is unrelated. But the solution also worked :slight_smile:

The problem with the Rasa Ephemeral Installer persists.

Sorry, which solution worked exactly?

I have the same problem, deployed with helm on a k8s cluster and never touched the Rasa Ephemeral Installer nor the rasactl command so far.

Hi @JiRadu, welcome to the RASA community. This video explains the installation quite well: Installing and Deploying Rasa X (Using Rasa Ephemeral Installer) - YouTube

Unfortunately the written documentation is not so clear about it. I was missing a Rasa Open Source installation (which is not contained in Rasa X by default). You can add this by adding these lines to your values.yml file. (If you haven’t created one yet, this is simply a new file you create on the server you want to run Rase X on).

      enabled: true
      enabled: true

afterwards you have to update your Rasa installation with rasactl update —values-file values.yml.

I hope this helps you. (if not just let me know),

Have a great day,


Hey. @soerenetler . What version of RASA are you using with Rasa X? I was also following the tutorial, but this installs RASA 2.8, instead of newer version, which are claimed to work with RASA X and defining new versions, as shown in docs, only gets the RASA X deployment stuck on “Updating”. (Upgrading Rasa X Versions)

I use rasa open source 3.1 and rasa x 1.1. by adding the following lines to the values.yml.

  tag: "1.1.0"
  tag: "1.1.0"
  tag: "1.1.0"
       enabled: true
       enabled: true
   tag: "3.1.0-full"

Maybe adding --verbose to the command can give more information. rasactl update —values-file values.yml --verbose

Thank you for your response. I did indeed succeed in connecting all the components of the helm and running them with provided details.