Rasa X UI hangs when rasactl starts with endpoints configuration


I run RASA X 1.1.1 on a docker on my Mac. I use rasactl connect rasa to connect a rasa server to rasa x. When I start with “rasactl connect rasa” everything works fine.

As I want to run an action server on localhost as well I start

rasa run actions

in another terminal:

2022-06-01 22:50:53 INFO rasa_sdk.endpoint - Starting action endpoint server… 2022-06-01 22:50:53 INFO rasa_sdk.executor - Registered function for ‘action_hello_world’. 2022-06-01 22:50:53 INFO rasa_sdk.endpoint - Action endpoint is up and running on

I use the following entry in endpoints.yml:

action_endpoint: url: “

When I start the rasa server now with:

rasactl connect rasa --extra-args="–endpoints=endpoints.yml"

then after entering text in “Talk to your bot”, rasa X displays my input, shows the icon indicating that it is processing my input and hangs. It never prompts a response.

So, how can I use custom actions in my model and test it using Rasa X?

Any help is appreciated!


1 Like

HI, also had same issue in dockerized rasa (open source) & how i fixed it :point_down:t2::point_down:t2:

Create docker network

docker network create mynet

edit your endpoint.yml

url: "http://actions:5005/webhook"

train the model

docker run -it --rm --user 1000 --network mynet -p5055:5055 -v $(pwd):/app rasa/rasa:3.0.0 train

RUN Rasa actions

docker run -it --rm --user 1000 --name actions --network mynet -v $(pwd):/app rasa/rasa:3.0.0 run actions

RUN Rasa Shell

docker run -it --rm --user 1000 --network mynet -p5055:5055 -v $(pwd):/app rasa/rasa:3.0.0 shell