Rasa X Custom Actions

Hi,

I am new to RASA and I have just installed RASA X with docker (quick installation). I have successfully got it working and able to create stories. Now I want to put my hands on custom actions. Following the docs, I have created a directory named “actions” under /etc/rasa and created 2 files init.py (empty file) and actions.py (with a custom action). Now when I chat with the bot, it detects the intent by does not respond with anything. I am not sure how to see the logs to see if it is even talking the custom action. Can someone please help.

You’ll need to replace the default app image with your own custom action server image. See connecting a custom action server.

One quick question though @mloubser to avoid creating a new topic while I’m having similar problems. What if you have filled up the docker-compose.override.yml taken it up again and then also changed the endpoints.yml to contain http://action_server:5055/webhook and yet still, actions won’t trigger.

@ktoulgaridis what are you seeing in the logs for your app container? Are you seeing errors in the logs for rasa-production (or whichever environment you are using) about not being able to run custom actions when talking to the bot?

Thanks for the quite speedy reply,

Failed to run custom action 'action_greet_user'. Couldn't connect to the server at 'http://action_server:5055/webhook'. Is the server running? Error: Cannot connect to host action_server:5055 ssl:default [Name or service not known]

I don’t believe you need to change the endpoints file, only the docker-compose.override.yml. In a successful deployment with a custom action server, my endpoints.yml contains

action_endpoint:
  url: ${RASA_USER_APP}/webhook
  token:  ""
1 Like

Even though I have added the docker-compose.override.yml I still get this error. Can you please tell me what might I be missing? P.S I have a docker image running my action server @stephens

Solved it by adding expose: -5055 in the docker-compose.override.yml