RASA X :Something went wrong

  • The talk to your bot option of the page is struck at Something went wrong. Rest every option works well in rasa x atm.
  • rasa run, rasa shell works perfectly.
  • Also I’m unable to find the logs for rasa x

Deleting rasa.db, tracker.db and __init__.py resets rasa x completely but it again incurs error when I train a new model and switch it to production using rasa x interface

Is there anything in the logs or does the network tab in the developer console of your browser show any failed requests?

Your Rasa model is trained and saved at ‘/home/iamtheuserofthis/Python_Workspace/python_chatbot2/rasa_x_t/models/20190529-100643.tar.gz’.
2019-05-29 10:07:16 ERROR rasa.core.channels.channel - An exception occured while handling user message ‘hi’.
Traceback (most recent call last): File “/home/iamtheuserofthis/anaconda3/envs/py_chat_v3/lib/python3.7/site-packages/rasa/core/channels/channel.py”, line 447, in receive
text, collector, sender_id, input_channel=self.name()
File “/home/iamtheuserofthis/anaconda3/envs/py_chat_v3/lib/python3.7/site-packages/rasa/core/channels/channel.py”, line 68, in handler
await app.agent.handle_message(*args, **kwargs)
File “/home/iamtheuserofthis/anaconda3/envs/py_chat_v3/lib/python3.7/site-packages/rasa/core/agent.py”, line 441, in handle_message
return await processor.handle_message(message)
File “/home/iamtheuserofthis/anaconda3/envs/py_chat_v3/lib/python3.7/site-packages/rasa/core/processor.py”, line 74, in handle_message
await self._predict_and_execute_next_action(message, tracker)
File “/home/iamtheuserofthis/anaconda3/envs/py_chat_v3/lib/python3.7/site-packages/rasa/core/processor.py”, line 339, in _predict_and_execute_next_action
action, policy, confidence = self.predict_next_action(tracker)
File “/home/iamtheuserofthis/anaconda3/envs/py_chat_v3/lib/python3.7/site-packages/rasa/core/processor.py”, line 164, in predict_next_action
action_confidences, policy = self._get_next_action_probabilities(tracker) File “/home/iamtheuserofthis/anaconda3/envs/py_chat_v3/lib/python3.7/site-packages/rasa/core/processor.py”, line 552, in _get_next_action_probabilities tracker, self.domain File “/home/iamtheuserofthis/anaconda3/envs/py_chat_v3/lib/python3.7/site-packages/rasa/core/policies/ensemble.py”, line 342, in probabilities_using_best_policy probabilities = p.predict_action_probabilities(tracker, domain)
File “/home/iamtheuserofthis/anaconda3/envs/py_chat_v3/lib/python3.7/site-packages/rasa/core/policies/fallback.py”, line 101, in predict_action_probabilities
nlu_confidence = nlu_data.get(“intent”, {}).get(“confidence”, 1.0)
AttributeError: ‘NoneType’ object has no attribute ‘get’

This happens when I switch a freshly trained model using rasa x to production under the models option.

Something similar also happens when I try to import conversations from tracker store using the migrate_tracker_store_to_rasa_x.py script. The script however worked fine with the conversations that took place with previous versions of rasa, but errors out when trying to import conversations stored with rasa 1.0. I am using mongo as tracker store

I tried a few different things and for me there is just one point of failure in rasa x.

When I train a model using rasa x the tar of the model generated is not usable by the rasa core pipeline.

Due to this the tracker store also incurs some error in the mongo store. When this happens then I’m not able to import data using the migrate_tracker_store_to_rasa_x.py store and the rasa.db and tracker.db.\

If I train multiple models using rasa train and then start rasa x, then switching models to production is carried out smoothly in rasa x
It might be that the problem is the way I’ve configured it for my use. But I’m not sure
@Tobias_Wochinger, sorry I forgot to tag you in the follow-up idk if you were notified. But it seems like how people communicate on here.

Do your models contain any nlu data? Can you try to install the latest rasa x version?

Resolved with the new version. Thanks @Tobias_Wochinger

Awesome! :sunny: