Rasa X error when run, task pending, error asyncio, error concurrent.future

I’m new to Rasa and found this error when trying to run rasa x.

can someone help me? @nik202

@ShrimpGatari were you able to chat with the bot using rasa x? please share rasa --version whilst activating env. Thanks.

@nik202 I cant chat with the rasa x, in the browser, it shows this one. image

This is my version image

@nik202 Are there any alternatives to train the chatbot from user conversation instead of rasa x?

@ShrimpGatari are you able to see the Rasa x in the browser?

Tip: try install rasa==3.0.x ?

@nik202 I can’t see the Rasa x in the browser it shows an error occurred while handling an error. like the above picture shown.

I tried to install rasa 3.0.x but it can’t. It says no matching distribution was found… I thought maybe it was because of the pip version… So I tried to upgrade the pip but this happens…

@nik202 I manage to install rasa v3.0.6

but the problem is still there

@akelad can you also help me solve this problem? Sorry for any inconvenience

@ShrimpGatari are you able to talk to the bot or are you getting some errors except the above one?

I can talk to the bot thru rasa interactive, rasa shell. But when I tried using rasa x it shows the error. it did open the rasa x web, but it only display an error that occurred while handling an error. image

btw, thank u so much for hearing me out, really appreciate it.

@koaning can u help me with this problem?

hi, everyone! this problem is not yet solved but I did manage to run rasa x on another version. I downgrade my rasa os and rasa x to this (rasa == 2.8.7, rasa-sdk == 2.8.2, rasa-x == 0.42.2).

best of luck to all of u!

Thanks for the discussion and help! I was interested to find out what solutions there are.