Rasa X showing in sync with Github but is not

I have azure ubuntu set up as rasa x server.

I am using it from past couple of months. During this time, I have pushed the code to Github and it was getting reflected to Rasa X as well. However, from past few days, it is not getting synced up.

I have also tried updating the Rasa X version from 0.31.5 to the latest - 0.32.2 but the issue still persists.

Also, whenever I try to upload domain file manually, that is giving me error with code 500.

Please suggest me what can be done! Thanks in advance.

Hi, I got to know the issue. After debugging through the rasa pod using command

kubectl --namespace rasa logs <rasa x pod name>

I saw that the error was given through SQLAlchemy which said, my slot value was greater than the set size for char. (There was a list in my slots which was having length longer than 255) and led to failure in pulling data to rasa-x. Well, this wasn’t an issue when I ran the bot locally so, did not realise it could create problem.

I changed the value of this slot to a smaller length and it worked!

@Tobias_Wochinger I saw a similar issue on in git, so tagging you to suggest, it’ll be good if we could get these issues shown upfront instead of showing just a http status as 500.