Rasa x Requirement already satisfied: rasa-x in site-packages (0.0.1)

I encounterd problems in installing rasa-x, the message that always appears:

(hellorasa) C:\Users\eng.ghadyalhamad>pip3 install rasa-x --pre --extra-index-url https://pypi.rasa.com/simple
Looking in indexes: https://pypi.org/simple, https://pypi.rasa.com/simple
Requirement already satisfied: rasa-x in c:\programdata\miniconda3\envs\hellorasa\lib\site-packages (0.0.1)

I also tried: pip3 install rasa-x --pre --extra-index-url https://pypi.rasa.com/simple

and pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

Eventhough I re-install miniconda 3 and rasa.

Rasa info: Rasa Version : 2.8.7

Minimum Compatible Version: 2.8.0
Rasa SDK Version  :         2.8.2
Rasa X Version    :         None
Python Version    :         3.8.0
Operating System  :         Windows-10-10.0.19041-SP0
Python Path       :         C:\ProgramData\Miniconda3\envs\hellorasa\python.exe

What’s wrong?? please help

@GhadyAlhamad I’d recommend please try use this command for installing rasa x, in latest version you will see some error, till the time latest version is more stable please use rasa 0.39.3

pip install rasa-x==0.39.3 --extra-index-url https://pypi.rasa.com/simple

Note If not?: You must install anaconda(Anaconda | Individual Edition), then create virtual environment and install rasa (pip install rasa==2.8.1) and then install rasa x.

As, you mentioned Miniconda 3, I not personally used, and as per recommendation by rasa they also suggest Anaconda environment so, give it a try.

If you have any doubt please feel free to ask. Good Luck!

1 Like

Thank you for reply, please check the result:

PS D:\MyWorks\ChatBot> pip install rasa-x==0.39.3 --extra-index-url https://pypi.rasa.com/simple
Looking in indexes: https://pypi.org/simple, https://pypi.rasa.com/simple
ERROR: Could not find a version that satisfies the requirement rasa-x==0.39.3 (from versions: 0.0.0, 0.0.1, 0.0.2)
ERROR: No matching distribution found for rasa-x==0.39.3

@GhadyAlhamad you are using miniconda I guess that’s why the issue, can you install anaconda please and then try install? I already mentioned in my previous post.

@GhadyAlhamad Complete solution.

I’d recommend to create a fresh conda environment with python 3.8 and follow the step

`pip install rasa==2.8.1`
`pip install rasa-sdk==2.8.1'

check version rasa --version its install or not


pip install rasa-x==0.39.3 --extra-index-url https://pypi.rasa.com/simple

check rasa version rasa --version its install or not

You will see some error : ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ Install

pip install SQLAlchemy==1.3.22 should fix it

If sanic related error: pip install sanic-jwt==1.6.0

delete .db if is showing alembic issue.

Good luck! I hope this will solve your issue. Please mention me as @ and nik202 for direct notification.

OK, I will try… but right now I noticed that I have problem with block ! So, I wanna ask if I can download rasa-x from another link and install it manually??

@GhadyAlhamad No, that will not solve your issue and I guess the available command is that only and which solution I suggested is currently more stable. But, I would encourage please install anaconda, create env and install rasa and rasa-x.

@GhadyAlhamad may be you can try with pip3 install … ?

 pip3 install rasa-x==0.32.2 --extra-index-url https://pypi.rasa.com/simple
Looking in indexes: https://pypi.org/simple, https://pypi.rasa.com/simple
Collecting rasa-x==0.32.2
  ERROR: HTTP error 403 while getting https://pypi.rasa.com/api/package/rasa-x/rasa_x-0.32.2-py3-none-any.whl (from https://pypi.rasa.com/simple/rasa-x/)
ERROR: Could not install requirement rasa-x==0.32.2 from https://pypi.rasa.com/api/package/rasa-x/rasa_x-0.32.2-py3-none-any.whl because of HTTP error 403 Client Error: Forbidden for url: https://storage.googleapis.com/rasa-packages/cf70/rasa-x/rasa_x-0.32.2-py3-none-any.whl?Signature=JZiyHHjQguBIsoiTFpmI0k2n5Ah5gqyZof0jW3FkbogMg5%2BLOqaQLBKmniQ0aTiY921M%2F34DWsud%2BykqR2e4KsyKuLq2kNKB7Cv4NHs2UIZ77tOKmyeLt1fPJ7jcP8%2BSXACxpbcsziaRqf0%2BuQUHSMU%2BND6uWfE18Y0ZE6m0SZ81CP1BFRQhPtP45OOm%2FnLUrzEN7snbZVt0Mh%2BvB3DqkvgxlvzvpEQTdj9BT4rAPqsiHgce5j%2FibXE%2BD8tXoQ%2FPuZ4KwWNNpfdK4XWpR7yfUv1ehvZ2pLO0WVc7Svh%2BumP%2F27THRGGQw07aCROcFsLQXafVyg9SDJLVX6EEnHz8aA%3D%3D&Expires=1632508151&GoogleAccessId=pypi-storage%40pypi-190908.iam.gserviceaccount.com for URL https://pypi.rasa.com/api/package/rasa-x/rasa_x-0.32.2-py3-none-any.whl (from https://pypi.rasa.com/simple/rasa-x/)

With running HotSpot

@GhadyAlhamad I’m not getting you, what you trying to do? Are you able to install anaconda in your country? yes or no?

Regarding to anaconda for sure yes but as for rasa-x I don’t think so :frowning:

@GhadyAlhamad Please install Anaconda first and you will be able to install rasa x on that too… finger cross. Just try please.

1 Like

Unforunatly, as I expected I did all steps but no change ! :sleepy:

I need either good vpn or how can I install rasa-x manually because I could download file using mobile vpn.

After I downloaded rasa x and tried to install I got same message:

pip install rasa-x -i C:\Users\eng.ghadyalhamad\Desktop\rasa-x-0.32.0.tar.gz
Looking in indexes: c:\Users\eng.ghadyalhamad\Desktop\rasa-x-0.32.0.tar.gz
Requirement already satisfied: rasa-x in c:\programdata\anaconda3\envs\rasa\lib\site-packages (0.0.1)

@GhadyAlhamad are you able to solve this issue?