Rasa X rabbitmq password error

Hy everyone!

I’m try to run the “rasactl connect rasa”, but this message is printed:

both my rasa and rasa sdk version == 2.8 my rasaX version == 1.x

okay, i deleted everthing and create a kind-rasa again, but when i run “rasactl connect rasa” this is happen

@nik202 :sob:

@Wedrano-de-Carvalho what happens? Ok, Tell me the brief steps and rasa version you are installing?

@nik202 So, i follow this steps Installation and its all rigth, when i run “rasactl open” its opened in my browser (an empty dashboard), but when i run “rasactl connect rasa” in my project path this error is raised

rasa and rasa sdk version == 2.8

rasaX == 1.x

I did the steps described in the error, but nothing change

yap, maybe this exception is incorrigible :smiling_face_with_tear: i’ve try everything to pass this error, but nothing work… rasactl auth… send the the rabbitmq: auth: password:“rabbit” in the values.yaml file also doesn’t work… i’m dead at this point :confused:

@Wedrano-de-Carvalho can you see this please and check your password ? Configuration

@nik202 when i run the steps in that link to catch rabbit secret this output comeback to me: password%

@Wedrano-de-Carvalho please install everything again.

@nik202 man, what command can i use to uninstall all this? i’m not finding it anywhere hahah in usr/local/bin/ also have nothing

@Wedrano-de-Carvalho share with me some screenshots or methods you followed?

@nik202 okay, let’s go.

1° — i’ve install rasaX with REI.sh file and its work (but the rasaX UI its all empty of course), rasaX version 1.0.1 ~~~ 2º i try to connect the rasaX with my rasaOSS betwen Event Broker (Connect Rasa Open Source to Rasa X) but when i put this 1 in my values.yaml file and run the command rasactl upgrade [my deploy env name] --values-file values.yaml this error is raised → https://forum.rasa.com/uploads/default/optimized/3X/a/f/afae2a4387c6eef2909dcae49eafd26a4e6308bf_2_690x312.png. its raised also if i run the command rasactl connect rasa in my project folder and in the documentation it says it’s supposed to work. So i’m feel like defeated by this method and change my approach. Now i’ve been try to pass the values.yalm when i create an environment (rasactl start [env name] --values-file values.yaml), not when i upgrade. But now this error its raised Rasa-x-rabbit without a load balancer service i’m going crazy bro hahah

rasa -v 2.8.14
rasa-sdk 2.8.3
rasaX -v 1.0.1

@Wedrano-de-Carvalho Let me see this, but meanwhile you try figure out how to completely delete the installation.

@Wedrano-de-Carvalho any luck?

@nik202 nooo, I had to downgrade the rasaX to v0.42. this error belongs to rabbitmq charts, not rasa’s fault

@nik202 I’m sad that I missed the git integration, but what can I do, life is like that hahah

@Wedrano-de-Carvalho when I am here why you sad again :slight_smile: tell me what is the persistent issue?

1 Like

@nik202 now I don’t have any problem because I changed the rasaX version, but in rasaX v1.0.1 (REI install) the above mentioned error keeps happening. at least it wasn’t the project I’m releasing to production, but that combination between rasa OSS and rasaX (rei install) doesn’t work. What makes me sad is rasaX v 0.42.x doesn’t have git integration, this is a feature of v1.0.1 but this is not a problem that I can’t work around. Thanks for you support, I don’t have more time to invest in fixing this error… byy o/

@Wedrano-de-Carvalho local installation right?