Rasa X quick install script on Ubuntu 20.04 not working

Hey all, I am not able to geht the rasa x quick install script working on Ubuntu 20.04 (also tried on debian 10). I tried severall configurations with rasa x and rasa versions and also with the installer_debug_mode, but it remains stuck in the “Deploying Rasa X…” state. Debug is saying.

error: timed out waiting for the condition on deployments/rasa-rasa-x
NAME                                   READY   STATUS              RESTARTS   AGE
rasa-db-migration-service-0            0/1     ContainerCreating   0          43s
rasa-rasa-worker-699d6464b4-rb2vf      0/1     Init:0/1            0          43s
rasa-event-service-6fc8c56697-zx69k    0/1     Init:0/1            0          43s
rasa-rasa-production-b954fd599-hgzxm   0/1     Init:0/1            0          43s
rasa-rasa-x-7f4955c458-sb7hj           0/1     ContainerCreating   0          43s
rasa-app-7b77c5755d-4qjqh              0/1     ErrImagePull        0          43s
rasa-nginx-7f4677647c-h5zt8            1/1     Running             0          43s
rasa-redis-master-0                    0/1     Error               0          43s
rasa-postgresql-0                      0/1     CrashLoopBackOff    1          43s
rasa-rabbit-0                          0/1     Error               0          43s

The states are changing, but I guess the problem is with the rasa-app. Does anyone have a solution?


Hi Simon, I had the same problem and could’t sove it with the quick install script. Using the Docker Compose Installation worked for me: https://rasa.com/docs/rasa-x/installation-and-setup/install/docker-compose

1 Like

Thanks! Worked for me aswell - also if I would switch back to the quick install script as soon as it is running again :slight_smile:

Another hint: When using the docker compose installation, setting up SSL did not work with the instructions in the rasa docs. However, this post helped me solving the issue.

Same here, I really thought something was wrong with my setup. Will try the docker compose install then :confused: Thanks