Rasa X on server not updating from Gitlab-Repo

Hi all!

I updated the nlu.md, stories.md.and the domain.yml files from my local PC to the gitlab-Repo that is connected to the Rasa X Server. As I understand, Rasa X will notice these changes and update automatically the server data. Actually that did work in the past. It took a while, but then everything worked nicely. But my last update today isn’t getting updated into Rasa X on the server. I just added responses and stories, nothing else. Pushing it to the Gitlab-Server, worked. But no update to the Rasa X Server.

What am I doing wrong?

Best regards!


1 Like

Hi @axelschweiss,

It should indeed work the way you describe it.

What version of Rasa X are you using?

I have a similar issue. Running the latest version of Rasa X. My NLU file on github has many values under a certain intent however in Rasa X the intent has zero values. Why is it not updating?

I’m having the same problem. Any updates?

Hi @robynbitner how did you solve your issues, I have the same problem.

Hi @Arjaan, My rasa x is not up to date with my git repo. I don’t know why. I am using the latest version of rasa. Please i need your help to solve this issues. Thank