I can't train my model

Hello everyone!

My Rasa X Server is deployed via docker. 2 weeks ago I upgraded my Rasa Version to 1.10.8, Rasa SDK to 1.10.2 and Rasa X to 0.30.1. Everything worked perfectly fine, I was able to train my model. Today I was changing the story of my bot uploaded it and wanted to train again, but training failed because of following error:

ERROR:rasax.community.api.blueprints.models:500, message=‘Internal Server Error’, url=URL(‘http://rasa-worker:5005/model/train?token=2776879774’)

The logs of my rasa worker container only show following content:

** 2020-08-06 09:19:34 ERROR pika.adapters.utils.connection_workflow - AMQPConnector - reporting failure: AMQPConnectorSocketConnectError: ConnectionRefusedError(111, 'Connection refused')

2020-08-06 09:19:54.528873: E tensorflow/stream_executor/cuda/cuda_driver.cc:351] failed call to cuInit: UNKNOWN ERROR (303)**

Does anyone know how it is possible to destroy my whole Rasa X server uploading a new story file? Has anyone experienced the same situation before? Older threads did not help, mostly it was a versioning error but the versions I use are all compatible according to the docs.

Thanks in advance

I’m having a similar problem.

Ubuntu Server 16.04 LTS Python 3.5.2 Docker version 19.03.12, build 48a66213fe docker-compose version 1.26.0, build d4451659 RASA_X_VERSION=0.31.3 RASA_VERSION=1.10.8 RASA_X_DEMO_VERSION=0.31.0

I’ve got the same problem since last Friday …
The rasa worker log is empty :

Attaching to docker_rasa-worker_1
rasa-worker_1      | 2020-08-10 14:12:35.570798: E tensorflow/stream_executor/cuda/cuda_driver.cc:351] failed call to cuInit: UNKNOWN ERROR (303)

Rasa 1.10.8
Rasa-x: 0.31.4
Rasa-sdk: 1.10.2
Spacy 2.3.0, fr large

1 Like

I am having a similar problem as the one described above. However in my case the logs from the rasa worker are completely empty. Training (or uploading models) fails for me and I am getting this error: ERROR:rasax.community.api.blueprints.models:500, message='Internal Server Error', url=URL('http://rasa-worker:5005/model/train?token=rnyL9iBRVkzsW7f') I have no clue what I should be looking for. @erohmensing Maybe you can help us?

EDIT: This problem appears to be very common at the moment, I found plenty of threads reporting the same. These for example: 1, 2, 3. Could it be a problem with the current Rasa X version?

1 Like

@stefanpenzinger, @emorycardozo, @JosephCHS has anyone of you found a solution yet?

1 Like

I have solved my problem by:

  • modifying the spacy model (large to medium)
  • removing two breaking lines that I have forgotten in a file (nlu or story I don’t remember)

This error is too imprecise, it asks to check the log of the container worker which is empty.
It would be nice if she at least pointed us to the file that’s causing the problem.


Hello, it seemed to be a problem with the response selector which is not supported. Somehow in my training data there were still intents left and rasa x decided to help me out and implemented response selector on its own. After removing response selector from the config.yml and removing the nlu data related to retrieval actions everything worked out for me.

1 Like