Rasa x error after installation

Hello I could hardly install rasa-x on windows 10 I created a new environment with python=3.7.6. I downgraded numpy to 1.18.5. I downgraded many packages to remove all red installation errors. I tried all the above steps on mac and it worked nicely. But on my windows 10 machine , it seems every thing is ok and When I type “rasa init” or “rasa x”, it throws the following message and nothing happens.

(rasam) PS E:\rasam> rasa init c:\programdata\anaconda3\lib\site-packages\numpy_distributor_init.py:30: UserWarning: loaded more than 1 DLL from .libs: c:\programdata\anaconda3\lib\site-packages\numpy.libs\libopenblas.PYQHXLVVQ7VESDPUVUADXEVJOBGHJPAY.gfortran-win_amd64.dll c:\programdata\anaconda3\lib\site-packages\numpy.libs\libopenblas.WCDJNK7YVMPZQ2ME2ZZHJJRJ3JIKNDB7.gfortran-win_amd64.dll warnings.warn(“loaded more than 1 DLL from .libs:” Traceback (most recent call last): File “c:\programdata\anaconda3\lib\site-packages\numpy\core_init_.py”, line 24, in from . import multiarray File “c:\programdata\anaconda3\lib\site-packages\numpy\core\multiarray.py”, line 18, in from ._multiarray_umath import ( ImportError: cannot import name ‘_set_madvise_hugepage’ from ‘numpy.core._multiarray_umath’ (c:\programdata\anaconda3\lib\site-packages\numpy\core_multiarray_umath.cp38-win_amd64.pyd)

During handling of the above exception, another exception occurred:

Traceback (most recent call last): File “c:\programdata\anaconda3\lib\runpy.py”, line 194, in run_module_as_main return run_code(code, main_globals, None, File “c:\programdata\anaconda3\lib\runpy.py”, line 87, in run_code exec(code, run_globals) File "C:\ProgramData\Anaconda3\Scripts\rasa.exe_main.py", line 4, in File "c:\programdata\anaconda3\lib\site-packages\rasa_init.py", line 8, in from rasa.run import run File “c:\programdata\anaconda3\lib\site-packages\rasa\run.py”, line 8, in from rasa.core.lock_store import LockStore File "c:\programdata\anaconda3\lib\site-packages\rasa\core_init.py", line 5, in from rasa.core.train import train File “c:\programdata\anaconda3\lib\site-packages\rasa\core\train.py”, line 14, in from rasa.utils.common import TempDirectoryPath File “c:\programdata\anaconda3\lib\site-packages\rasa\utils\common.py”, line 9, in import rasa.core.utils File “c:\programdata\anaconda3\lib\site-packages\rasa\core\utils.py”, line 25, in import numpy as np File “c:\programdata\anaconda3\lib\site-packages\numpy_init_.py”, line 140, in from . import core File “c:\programdata\anaconda3\lib\site-packages\numpy\core_init_.py”, line 50, in raise ImportError(msg) ImportError:


Importing the numpy C-extensions failed. This error can happen for many reasons, often due to issues with your setup or how NumPy was installed.

We have compiled some common reasons and troubleshooting tips at:


Please note and check the following:

  • The Python version is: Python3.8 from “c:\programdata\anaconda3\python.exe”
  • The NumPy version is: “1.19.5”

and make sure that they are the versions you expect. Please carefully study the documentation linked above for further help.

Original error was: cannot import name ‘_set_madvise_hugepage’ from ‘numpy.core._multiarray_umath’ (c:\programdata\anaconda3\lib\site-packages\numpy\core_multiarray_umath.cp38-win_amd64.pyd) indent preformatted text by 4 spaces (rasam) PS E:\rasam>

Hi @khalid,

You say you are using numpy version 1.18.5, yet in the stack trace it says:

Maybe this is related to the problem?