Rasa X deployment issues on fresh VM

I have tried deploying Rasa X according to the documentation (Installation Guide)

I’m at my fourth try and the installation gets stuck at “Deploying Rasa X…”

Error (including full traceback): Checking the kubernetes pods, it looks like there’s a CrashLoopBackOff error on rasa-nginx. Further checking of the rasa-event-service pod shows the following:

bitnami@debian:~$ kubectl logs rasa-event-service-6fc8c56697-6rjt7
Unable to get database revision heads.
DB revision(s) do not match migration scripts revision(s):
DB revision: None
Migration scripts revision: ['652500998f3e']
Database revision does not match migrations' latest, trying again in 4 seconds.
Unable to get database revision heads.
DB revision(s) do not match migration scripts revision(s):
DB revision: None
Migration scripts revision: ['652500998f3e']
Database revision does not match migrations' latest, trying again in 4 seconds.
Unable to get database revision heads.
DB revision(s) do not match migration scripts revision(s):

Command or request that led to error:

curl -s get-rasa-x.rasa.com | sudo bash

Content of configuration file (config.yml) (if relevant):

Content of domain file (domain.yml) (if relevant):

This is the first install of the software on this VM. The VM is on an ESx. I have triple checked and I meet all the hardware requirements. There were no previous installs on it. It’s a fresh VM.

Rasa X version (if used & relevant): Deploying according to docs - I suppose it’s latest version

Python version: 3.7.3

Operating system: Debian 10

Can I have some feedback on this? Thank you! I’ve also opened a github issue

up!!!

@georgebrianb Heya! Can I asked one thing, you only want to install Rasa-X using Kubernetes, or are you comfortable working with Rasa Open Source OR its the requirement of your client?

I’m comfortable using Rasa Open Source, but my client would like to have the testing interface, the intuitive UI that comes with Rasa X, it’s how I sold the solution. It was this or DialogFlow, and I’m leaning towards changing everything now to the latter as I cannot lose any more time with issues like these.

He’s given me time until the 15th of August, maybe I can get some help by then!

@georgebrianb Please share your email id and I will provide a best solution.

@georgebrianb Please follow what we had discussed meanwhile later in the day, I will share some threads with you for your record. We will together solve you issue :slight_smile:

Edit: done! Thank you!

@georgebrianb As Discussed

Step1: Please run the code of chatbot on your Ubuntu Machine (VM) which is developed whilst using Rasa Open Source.

Terminal1: rasa run actions
Terminal2: rasa run -m models --enable-api --cors "*" --debug

Step2: Now, as you mentioned, you have website which is running on server 24/7 on Wordpress, copy the bot front JS snippet code in plugin header and footer (body section)

<script>!(function () {
  let e = document.createElement("script"),
    t = document.head || document.getElementsByTagName("head")[0];
  (e.src =
    "https://cdn.jsdelivr.net/npm/rasa-webchat@1.0.1/lib/index.js"),
    // Replace 1.x.x with the version that you want
    (e.async = !0),
    (e.onload = () => {
      window.WebChat.default(
        {
          customData: { language: "en" },
          socketUrl: "https://localhost:5005",
          // add other props here
        },
        null
      );
    }),
    t.insertBefore(e, t.firstChild);
})();
</script>

Note: Version 1.0.1 for latest above 2,4.X as mention GitHub - botfront/rasa-webchat: A feature-rich chat widget for Rasa and Botfront

Step3: Using Ngrok

Create the ngrok account, download ngrok for Ubuntu, validate the token of ngrok whilst inside the ngrok folder only.

Termina 3:

Command1 for Mac: ngrok Xyz$ ./ngrok http 5005
Command2 for Window: c:.....ngrok> ngrok http 5005

You will able to see a free plan of ngrok with session status online

Copy Forwarding last link: https://4c9f4f0d97cd.ngrok.io

Note: Every time you stop and run the ngrok for 5005, it will change the link, so you need copy and paste to the location which I will suggest in next step

Step4 : Replace then SocketUrl : “https://4c9f4f0d97cd.ngrok.io”,

Step5: Always smile :slight_smile:

Good Luck! If you are not able to perform anything from the above steps; or if some typo error, sorry in advance. Hope this will solve your issue.

Note: This solution is only for Rasa Open Source. I will request please change the topic category to Rasa Open Source.

Thanks a lot @nik202 !!

@georgebrianb Are you able to run as we discussed or using these above steps?