RASA-X cann't get conversation?

installed with docker-compose mannual , and can trian model ,bug failed conversation and interaction

i see logs in docker bellow: GET http://rasa-x:5002/api/projects/default/models/tags/production?token=cj3P2Yigf2LFQTq 204 0 GET http://rasa-x:5002/api/projects/default/models/tags/production?token=cj3P2Yigf2LFQTq 204 0 and GET http://rasa-x:5002/api/projects/default/models/tags/production?token=cj3P2Yigf2LFQTq 404 160

installed paras: image

when i type β€œhi” the robot pendding in answering

met too rasa version : 2.3.3 rasa x version: 0.37

@bruce1 and father-liang Hi! Please try to upgrade to 2.8.1 both for Rasa and Rasa-SDK and for Rasa X to 0.39.3, you will see some installation issues, do post if you face and see the issue persist or not. Good Luck!

thank you ,I wil try

same issue image

image

@bruce1 Sorry for late reply, was busy in meetings. I guess you need to prune the images and volume both.

Step1: Prune both Images and Volumes

docker image prune Ref link: docker image prune | Docker Documentation docker volume prune Ref link: docker volume prune | Docker Documentation

Step2: Delete all the containers, for the safer side, if that not work for you

docker rm -f <container ID>

Ref link: docker rm | Docker Documentation

Step3: Build again the image and then see if any file is excited whilst using

docker ps -a

Step4: The most important, as I can see you using PostgresSQL image, so if the container IP is not matched with Tracker store URL, it can also throw errors.

I will suggest, first try install rasa-X and fixed the issue, and then install other images.

I hope you install docker desktop or extension for VS Code. I’m sorry if you following some different processes for installing Rasa-X apologize in advance. Do let me know, if not work, and do share the complete screenshot of the error and docker ps. Good Luck!

thanks your reply, PostgresSQL is not my customized choose, i just follow Rasa: Developer Documentation Portal | Rasa. and i am afraind prune docker image can’t fix, actually i reinstalled many times even reinstall cenos7 system. i tried many method follow https://rasa.com/docs/rasa-x/installation-and-setup but failed

  1. tried Docker Compose Installation by installation Script:
  1. Reinsall centos 7 system and install docker(20.10.7),docker-compose 1.26.0
  2. curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/0.42.0/install.sh
  3. sudo bash ./install.sh
  4. cd /etc/rasa sudo docker-compose up -d

the /etc/rasa/.env. bellow:

image

docker-compose logs -f bellow: looksrasa-x_1 have some issue?? 404 page

docker ps, A total of 10 services:

after all service up, i create user

 [root@hk rasa]# python3 rasa_x_commands.py create --update admin me 123456
    Password successfully updated for user me.
    INFO:__main__:Created user.

befor i login rasa x on web-ui, i checked service log one by one :

a) i checked nginx service log, looks good:

b) checked rasa-x demo service, looks good: c) checked rasa_rasa-production_1 and rasa_rasa-worker_1 service, logs are empty. i guess didn’t do any task in rasa-x , so the rasa-production and work service can’t print anything,right? image

d) checked rasa_db-migration_1 service, looks good:

e) checked rasa_rasa-x_1 service ,there are some issue: :frowning_face: :frowning_face: :frowning_face:

f) checked rasa_duckling_1, good:

image

g) checked postgre, looks good:

h) checked rasa_rabbit_1 looks good:

i) checked rasa_redis_1 ,looks good, but with some warning:

@bruce1 May be lower Version of rasa work for you i.e 0.39.3 ? Give it a try and do let me know please. I can see you have done everything, and I wish you solved this issue soon. Best of luck Xu

only change rasa_x_version=0.39.3?? the issue same.

image

and get error on rasa_rasa-production

1

@bruce1 What is rasa_x_demo_version? do we need to change that too? @bruce1 You getting this while installing rasa x using docker, but last screenshot seems that there is no policy or and timezone can be duckling issue.

1 Like

rasa_x_demo_version=0.42.0, last screen showed,

and now changed rasa_x_version=0.39.3 and rasa_x_demo_version=0.38.0 and rasa_version=2.8.0_full befor train model, there still have 404 error???:

after i trained model , got 204 info:

i think GET http://rasa-x:5002/api/projects/default/models/tags/production?token=zghixctJsPxvHb5 have some issue lead to any model predict request failed

i think that is my mistake, i only set intent and response, didn’t write any story and didn’t train any model, after that enter to interactive conversation, so the assistant can’t provide any message.

once i write a story in ui , and active a model ,every thing is going right

thank you very much again

@bruce1 I would encourage, use some of these project GitHub - cedextech/rasa-chatbot-templates: RASA chatbot use case boilerplate as a reference for writing the stories or even clone. Good Luck!

ok i will try