Rasa webchat not showing(socketio)

i was able to use rasa webchat integration using botfront and socket.io last year. i had the javascript and frontend files ready in hope that i will just install rasa again and run it and the chatbot would work just fine. but today i installed rasa(obv the latest version i guess) and now the chatbot doesn’t show up. funny thing is that it actually shows no console error like those cors policy and all, NADA errors. just a plain blank page.

yes i changed the credentials file by un-commenting the socket.io code. and i run rasa server with rasa run -m models --enable-api --cors “*”. i just dont get it why it used to work 9 months back but now all of a sudden its just blank screen, not even an error.

attaching images in order of - socketio(credentials), index file(chat widget), rasa terminal, chrome console

@aryan192002 Does the bot respond when you talk to it via rasa shell? What about if you try using the rest channel? Just want to verify is that is an issue with socket.io channel

yo so i actually hopped on to botfront’s repo on github and well yeah its more like rasa-socket issue. rasa’s latest version doesn’t quite sit well with botfront’s present version(maybe socket io versioning bug) so they are on it,will prolly fix it in coming updates. alternatively folks cant give it a try updating socketio with npm .until official fix, i am using chatroom and customising it to my needs. thanks though.

i am getting the same error

facing the same problem. @aryan192002 did you solve your issue?

I am facing the same issue