Rasa Webchat Error

Hi I tried to integrate my local rasa chatbot with web referring to this GitHub - botfront/rasa-webchat: A feature-rich chat widget for Rasa and Botfront

My chabot worked fine in shell and rasa x. I tried many times integrated but got the same error.

My rasa version is 2.4.3, python-engineio==3.13.2, python-socketio==4.6.1

[2021-05-03 17:45:08 +0800] [3728] [ERROR] Exception occurred while handling uri: ‘http://localhost:5005/socket.io/?EIO=3&transport=polling&t=NandW0t’ Traceback (most recent call last): File “c:\users\59186\anaconda3\envs\rasa\lib\site-packages\sanic\app.py”, line 931, in handle_request response = await response File “c:\users\59186\anaconda3\envs\rasa\lib\site-packages\engineio\asyncio_server.py”, line 226, in handle_request ), environ) File “c:\users\59186\anaconda3\envs\rasa\lib\site-packages\engineio\asyncio_server.py”, line 379, in _make_response response_dict[‘response’], environ) File “c:\users\59186\anaconda3\envs\rasa\lib\site-packages\engineio\async_drivers\sanic.py”, line 103, in make_response status=int(status.split()[0]), headers=headers_dict) TypeError: init() got an unexpected keyword argument ‘body_bytes’

Hope someone can help me, thanks!

Hi @kiwoo, this issue related to Socket.IO has been resolved in Rasa 2.5.0.

Thank you for reply. But it doesn’t work for me. I upgraded to rasa 2.6 and rasa x 0.39

In credentials.yml: socketio: user_message_evt: user_uttered bot_message_evt: bot_uttered session_persistence: true

@kiwoo Is your problem solved?