Rasa Chat Widget with RASA-X 1.1.0 and RASA Open Source 3.1

Hi everyone,

I am trying to connect the Rasa Chat Widget (https://www.npmjs.com/package/@rasahq/rasa-chat) to my RASA X installation. I get the following error message.

[ERROR] Exception occurred while handling uri: 'ws://blubot.blauedaecher.com/socket.io/?EIO=4&transport=websocket&sid=L_SclJt9oF9vj2VgAAAC'
Traceback (most recent call last):
  File "handle_request", line 124, in handle_request
sanic.exceptions.ServerError: Invalid response type None (need HTTPResponse)

This error is also mentioned here (Socket Channel not working in rasa 3.0.0 · Issue #10412 · RasaHQ/rasa · GitHub) and there is a fix with different dependency versions (Problem with websockets - #13 by Vast)

How ca I implement that with Rasa X? What is the Rasa image I should use.

Thank you in advance,


For me downgrading to 3.0.10 and upgrading to 3.1. did the trick and it works now.

Where you able to Run Rasa X 1.1.0 with Rasa Open Source Framework 3.1.0? In my case this is failing.

yes, that worked for me. What is your error?

Here you have it: Rasa X not working after model is loaded

Well, apparently what was missing from my side after re-training locally with scipy 1.7.3 and uploading back to Rasa X was to refresh the browser’s cache. Now it’s working :slight_smile: