Rasa train nlu --data not working

version: Rasa 1.2.5

according to the docs it is Command Line Interface

rasa train nlu --data d:\rasa-tutorials-master\rasa_satya\data\rasa-training.json

usage: rasa [-h] [–version] {init,run,shell,train,interactive,test,visualize,data,x} … rasa: error: unrecognized arguments: --data d:\rasa-tutorials-master\rasa_satya\data\rasa-training.json

please let me know how to train a different file other than nlud.json or nlu.md @Juste

Hi @satyaveeravemisetti,

on which OS are you working? If it is Windows, then your path is malformed!? Did you provide the rest of the missing parameters aswell?


I use windows, i tried different ways, i would be very much happy if you can provide the exact command to train.



please move to your bot directory, in which a directory data should reside in. Then use:

rasa train --data data/ -c config.yml -d domain.yml --out models/

Regards Julian

Thanks it worked. No need to mention nlu for training nlu? If i want to train core then how should i do? Thanks.

if you want to train nlu only you need to use following command (switches):

rasa train nlu --nlu training_data/nlu --config configuration/config.yml

It’s interesting if you train nlu or core separately you have to use different switch for --data in case of nlu it’s --nlu in case of core it’s --stories.

changing your command from

rasa train nlu --data d:\rasa-tutorials-master\rasa_satya\data\rasa-training.json


rasa train --data d:\rasa-tutorials-master\rasa_satya\data\rasa-training.json nlu

works, nlu is a ppositional argument