Rasa shell segmentation fault

Hi there,

I used clean ubuntu 16 and ubuntu 18 server in wmware/virtualbox (8GB RAM) with python 3.6 and pip 20 in virtualenv to install rasa by github source. It built without errors. I tried to init a new project and speak to bot server during installation and good. After that, i enter the command with rasa shell, the segmentation fault occurred. It’s very strange that it works during the init project but fail with command rasa shell.

Can you help me, thanks!

Hey @samshaw. Looks like the issue here is related to your OS. I found the thread here which might be useful for you. Could you try some of the solutions mentioned here?

Thanks for help. I have tried the solution mentioned there with several times.

I did that in different computers with clean installation from ubuntu server 18 server LTS ISO file and follow the instructions:

by using from git source (because using pip install rasa will cause an sanic? package version dependency issue as forum already recolonized at this time)

$ sudo apt update $ sudo apt install python3-dev python3-pip $ sudo pip3 install -U pip

$ git clone https://github.com/RasaHQ/rasa.git $ cd rasa $ pip install -r requirements.txt $ pip install -e .

and rasa will installed successful without any errors.

However, I try rasa init (good, no problem) rasa shell (seg fault) test example restaurant and input rasa train (seg fault)

PS. I install ubuntu OS into windows vmware and virtualbox with 3 computers. all the same errors.

After testing with several computers and VM, finally I got the root cause: It’s the dependency issue, please just

pip uninstall gym pip install gym==0.15.4

then everything goes well. BTW, gym version was changed to 0.15.6 from 3th Feb, 2020. So, It’s the hot issue, isn’t it? ha ha

@samshaw good point, that would explain why we’ve been seeing so many more of these lately!