Rasa Action Server won't start

Hi, I’m new to Rasa and have an issue the following issue with the action server. In my project I have a package written by me from where I import some functions needed in actions.py and these imports cause the server to not run anymore. The imports are made like this:

from rb.utils.utils import str_to_lang from rb_api.keywords import keywords_extract from rb_api.textual_complexity import textual_complexity

and they cause the following:

I don’t know what I am missing.

Hi @adikinzor!

Could you please run it with debug flag to know more about why it is stoping?

The problem is that I tried both with -v and -vv and it does not output anything else

Run this command rasa run actions --debug

Hey I wrote earlier that I ran “rasa run actions -vv” which is the same and the output is not different.


Rasa Action Server doesn’t start for me too. Please help.

$ rasa run actions --debug

2020-06-01 07:35:49 INFO rasa_sdk.endpoint - Starting action endpoint server…

2020-06-01 07:35:49 INFO rasa_sdk.executor - Registered function for ‘action_search_restaurants’.

2020-06-01 07:35:49 DEBUG rasa_sdk.utils - Using the default number of Sanic workers (1).

At this point I do not see any more information displayed.

Please advise.

I ran below commands, it worked for me. In one terminal window: rasa init --no-prompt

In another terminal window: rasa shell

rasa init --no-prompt clears all existing configuration :frowning:

We need to get “rasa run actions” working.