Rasa loads latest model only, ignores -m model/{model.tar.gz}

(Using Rasa 2.4.0)

I am trying to have 2 rasa instances running concurrently with two separate servers. I want to initiate them using the rasa run -m models --enable-api command, and nothing else. The training data I provided is basic enough to run a simple model. In addition, the only difference in-between these instances is:

  • one is linked to Redis TrackerStore db1
  • the other one is liked to Redis TrackerStore db2.

The Core and NLU data is all the same for these who servers.

I trained one model with one configuration of the Redis db1 and started up the server. Then in the same exact working directory I trained the other model with the configuration of the Redis db2. Started the second server. The worked fine. The data was sent to the appropriate databases configured.

I took down the first server, the first db1 model I trained. When I start up the server again, by pointing to the appropriate model using rasa run -m models/{model.tar.gz} --enable-api, it connects to db2. Not db1 which I initially trained it on. I kept testing, even with the replace a new model API, and I noticed this is a pattern. Whenever I start up a server with a model that has a different configuration than the latest trained one, it ignores and takes the latest model. Although, it says the correct model was loaded.

Has anyone experienced this before? What could I do to force the server to take the model I wish to point to?

The tracker store is mentioned in the endpoints, not the model.

You should have two endpoint files and use --endpoints {endpoints.yml}.

1 Like