Rasa Installation on Ubuntu machine

Dear community,

I would like to deploy my chatbot on an AWS Ubuntu machine. Unfortunately I have again problems with the installation. Does the screenshots of the errors in my terminal seem familar to anybody? Help is appreciated a lot. Thank you

The requirements text file is from the Rasa Example project

Maybe, try installing rasa first and then after this .txt file. pip install rasa

@varunsapre10 unfortunately i got a lot of requirement errors, by just installing rasa first… That s why I had the idea to install it by using the requirements txt-file

Have you ever seen this before. I tried out many different things to install Rasa, but I run into errors all the time…

hey @StephanieHohenberg, can you try installing using the below command, may be it helps:

pip install rasa --upgrade tensorflow && PYTHONIOENCODING=‘UTF8’

Hey, @JiteshGaikwad can you kindly help with my chatbot project. i need to connect my chatbot to your UI but i can’t understand those steps you explained in your post. Thank you

Unfortunately it did not work. How did you come up with the command.

This is my problem now :smiley: It said MemoryError. I used your command with --user and --no-cache-dir but the MemoryError does not go away

Hey @StephanieHohenberg I think so it might be running out of memory because I have tested the command and it was working well on Ubuntu 18 and I came up with this command when I was not able to install tensorflow on one of AWS EC2 instance of Ubuntu machine.

Hey @vjaiswal693, how can I help you?

Alright. Thankyou @JiteshGaikwad So I probably just need to upgrade the AWS storage and then it works hopefully :crossed_fingers:

Hope so or it might be Memory related stuff or like RAM :sweat_smile: I don’t have much idea about that.