Rasa Init Command Not Found

Hello, Please does Rasa require any setup on my system, or do I have to install anything else before installing. I have installed it for the fifth time now each time uninstalling and creating new virtual environment and reinstalling it but each time I get the same error when I hit the rasa Init command it says rasa is not recognized as an operable program or batch file.

@Sopulu-max Hey! What steps you are following for installing rasa or rasa-x, could you please share in brief?

@Sopulu-max You need to start a fresh:

Need to install Anaconda First https://youtu.be/GlR60CvTh8A only follow the anaconda installation process, nothing more. If you installed already. Switch to below process.

create a project folder rasa

    1. conda create --name “Your_Environment_Name” python=3.8 or python==3.7.7
    2. conda activate Your_Environment_Name
    3. pip install pip==20.2 --user
    4. pip install rasa==2.8.1
    5. pip install rasa-sdk==2.8.1
    6. rasa init     follow the instructions
    7. running rasa type rasa shell 
    8. for training the bot rasa train
    9. In new separate terminal for custom action i.e action.py run rasa run actions

I would encourage use VS code and for activating environment Clt+Shift+P and select your condo environment.

Some of the reference projects: GitHub - cedextech/rasa-chatbot-templates: RASA chatbot use case boilerplate

Some reference course on Udemy (free) :https://www.udemy.com/course/rasa-for-beginners/

Tips: Read all the documentation or even see the videos of Rasa on Rasa youtube channels, be careful about syntaxs and other set’s of code.

Errors: Can arise some sets of dependencies errors, please just install as it mentioned but just install >= one only.

  • much common error is multidic please follow this pip install sanic==20.9.0 and then install pip install multidict==4.7.6

Note: If you feel like need a help do buzz us and we will happy to help you. Good Luck!

PS: Do change the topic category to rasa open source

Have you tried python -m rasa init?

Am stuck in step 4 and 5 seem that version of rasa no longer exists

@Sopulu-max Can you show the pip version

pip --version


pip install rasa[full]