Rasa HTTP API unreachable using in production with RASA X

Hi, I want to use inject an intent in a conversation from an external server that run our own company API using Rasa HTTP API.

We deploy the bot using Rasa X and when we call the Rasa HTTP API, it does not work. To inject intent, we use the Rasa X IPas the base url, like this: [IP]/conversations/{conversation_id}/trigger_intent=

Note also that we are using a token, that we are passing in the url.

Any clue ho to solve that please ? It was working before going to production with Rasa X.

Thanks in advance.

Hi @Rogers_ntr, to hit the production container directly, add the /core prefix to your endpoint. this tells nginx where to reroute the request, as it’s not a rasa x endpoint. So try:


Let me know if this doesn’t help!

Hi @erohmensing Thanks for the reply. It seems to work now, but I’m getting 401 error.

How do I get the access token ? I tried this, but didn’t get any response.

Hi @Rogers_ntr, the token is the RASA_TOKEN defined in your .env. You attach it via a query parameter token, so


Hi, Yes, I have been able to solve it by finding the predefined token created during Rasa X installation and it solved the problem.

Thanks deeply for your help! @erohmensing

No problem, good work figuring that out!