HTTP API /trigger_intent doesn't exist for RasaX

  • Rasa X 0.28.0
  • Rasa 1.10.0
  • Using postman to try this

Problem: I’m trying to trigger intent like this example does: curl -H "Content-Type: application/json" -X POST -d '{"name": "EXTERNAL_dry_plant", "entities": {"plant": "Orchid"}}' http://localhost:5005/conversations/38cc25d7e23e4dde800353751b7c2d3e/trigger_intent

/trigger_intent does not exist for Rasa X http api.

if I use /execute the action does run but after the uttered message there is this empty response and three dots keep loading.


is there an alternative that would do the same?


I got really close what I’m trying to achieve by using this: https://api/conversations/{conversation_id}/messages

The problem with this is that it makes latest_input_channel here rasa so bot utters to rasa, not to the channel user is using(socketio, facebook, slack…).

Solved using Reminders and External Events.

@k1m Can you please post your piece of code regarding this? I am trying to do the same and tried doing it with https://api/conversations/{conversation_id}/messages too, but unable to fetch the messages in my rasa code.


1 Like

I am facing the same thing now, I believe I aiming to the wrong endpoint.|

Did you manage to solve it ?